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DPA202T/103/2/2010 
 

Dear Student 
 
This tutorial letter is the manual for achieving the aim of study unit four.  It is only available in English.  The 
examination will include questions based on the competencies learned in this tutorial letter. 
 
As stipulated in the yearbook under the heading “General Information” we expect you to have access to the 
Microsoft Office Excel spreadsheet software or Open Office Calc (which can be downloaded free of charge from 
the Internet).  It is not our intention to give you a comprehensive knowledge of the Microsoft Office Excel or 
Open Office package, but rather to equip you with some basic principles so that you will be able to operate a 
spreadsheet package with ease.  Please note this tutorial letter is based on Microsoft Office Excel 2007 and you 
will need to make some adjustments if you are using Microsoft Office Excel 2003 or Open Office. 
 
You will find, when using the help key (F1), that there is more than one way of executing a command (e.g. 
mouse, keyboard and menu).  We will only show you some of the options, but in the exam, you are welcome to 
write down any command option you know.  However, for your answer to be correct, the command should be 
written down correctly and in the right order. 
 
A Microsoft Office Excel file, DPA202T_2010_TL103_1_E_activities data.xlsx, containing the data used in the 
activities, is available for download from myUnisa under Additional resources.  Please note this file only 
contains data and not any formulas or functions.  The Microsoft Office Excel file containing both the data and 
the completed formulas and functions are available from the lecturers.  The completed file will however only be 
made available to you if we receive your Microsoft Office Excel file with your attempts to complete all the 
activities. 
 
The best way to learn Microsoft Office Excel is to use it in your day-to-day work.  Always ask, “How can I do this 
task quicker and easier by using Microsoft Office Excel?”  There will be a Microsoft Office Excel discussion 
forum on myUnisa.  Please post your questions on this forum and please help your fellow students with answers 
to their questions.  Please also post Microsoft Office Excel functions and examples you personally found very 
useful in your day-to-day work.  Note this discussion forum is not limited to the functions covered in this tutorial 
letter.  We will check the discussion forum at least once a week and make sure you are still on the right track. 
 
Finally, we sincerely hope you enjoy the course, and that you will continue to benefit from it in the future.  All the 
best and every success with your studies - remember the only place where success is before work, is in the 
dictionary. 
 
Microsoft product screen shots used in this tutorial letter is reprinted with permission from Microsoft Corporation. 
 
Kind regards, 
 
Lecturer 
Miss. GM Viviers (Gerda) Miss. C Leonard (Christi)           
AJH van der Walt room 1-69 AJH van der Walt room 1-70 
Tel nr: (012) 429 3914 Tel nr: (012) 429 4025 
Cel nr: 072 683 6482             Cel nr: 072 683 6482 
Fax nr: 086 532 5869   Fax nr: 086 541 4855 
 
E-mail: 
First semester: DPA202T-10-S1@unisa.ac.za  
Second semester: DPA202T-10-S2@unisa.ac.za 
 
Fax: 
Fax number of Departement of Management Accounting: (012) 429-4894 
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4.5. Inserting a worksheet 
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7. Printing & Page layout 

7.1. Print area 

7.2. Page setup 

7.2.1. Page 

7.2.2. Margins 

7.2.3. Headers/footers 

7.2.4. Sheet (Gridlines and Row & Column headings) 

7.3. Print & Print preview 

8. Working with formulas 

8.1. Common errors when using formulas and functions 

8.2. Entering formulas 
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8.3.1.1. Copy down 

8.3.1.2. Copy across 
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9. Working with functions 
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9.2. Reference operators 

9.2.1. Colon (:) 
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9.4.6. Lookup functions (VLOOKUP) 

10. Working with data 

 
10.1. Sorting data 

10.2. Filter data 
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11. Working with charts 

 

11.1. Creating a chart 

11.2. Changing a chart 

11.2.1. Updating source data 

11.2.2. Changing chart types 

11.2.3. Changing the chart layout and format 

12. 
Frequent mistakes in Microsoft Office Excel questions (and how not to lose hard 
earned marks) 

 
Note: 
There are a number of shortcuts available in Microsoft Office Excel.  We have included some of these, 
under the heading shortcut. 

 
Where applicable TL103 will refer to this tutorial letter and ISBE will refer to the prescribed textbook, 
Information systems in a business environment (fourth edition). 

 
To get the most benefit out of this tutorial letter you should study it while working through all the 
examples and activities on Microsoft Office Excel.  (Yes! You really do need to have a computer 
for this!     ) 

 
 
 
 
 
 
 
 
 
 
 
 
1. BASIC PRINCIPLES TO REVISE BEFORE WORKING ON MICROSOFT OFFICE EXCEL 
 

For this subject it is a given that you have certain pre-existing mathematical and accounting 
knowledge and are able to apply that knowledge.  Paragraph 1 of TL103 is only emphasising 
some basic mathematics, accounting, etc. knowledge you already should have. 

 
1.1. Signs/operators 
 

Refer to paragraph 7.4.6.3 in ISBE 
 

Microsoft Office Excel uses in some instances different signs/operators than usually seen in 
mathematics.  Always use the applicable Microsoft Office Excel signs/operators and not the 
mathematical signs/operators when writing a Microsoft Office Excel formula.  The table below indicates 
the mathematical signs/operators with its associated Microsoft Office Excel signs/operators: 

 

 Mathematics Microsoft Office Excel 

Addition + + 

Subtraction - - 

Multiplication x * 

Division ÷ / 

Equal = = 

Brackets/parentheses ( ) ( ) 

Greater than > > 

Exponents a² ^ 

Less than < < 

Greater than or equal to >= >= 

Less than or equal to <= <= 

Not equal to ≠ <> 

 

For additional Microsoft Excel training guides, visit the Internet and do the following: 
• Type the following URL: http://www.microsoft.com/ 
• Select the ‘Help and How-to’ tab 
• At the left hand side of the webpage, find and click on ‘Training’ 
• At the left hand side of the webpage, find and click on ‘2007 Office System’ 
• Click on the ‘Excel 2007’ link 
• Now click on the  course you want to complete 
 
The above-mentioned link can also be found under Additional resources on myUnisa 
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1.2. Order of operation 
 

The order of operation is the sequence of computation a formula follows to get to an answer.  Microsoft 
Office Excel uses the same order of operations as mathematics and will therefore perform computations 
in the following sequence: 

 
• First:  Computations/calculations in parentheses/brackets, no matter where they are in the formula 
• Second:  Computations with exponents 
• Third:  Computations involving multiplication (*) and division (/) from left to right 
• Fourth:  Computations involving addition and subtraction from left to right 

 
10 + 10 * 5 = ?  What do you think the answer will be?  Microsoft Office Excel will first calculate 10*5 = 
50 and then add the 10 to the answer i.e. 10 + 10 * 5 = 60 

 
How do you write the formula if you want Microsoft Office Excel to first add the two 10’s together and 
then multiply the answer with 5?  What do you think?  Per the order of operation, we know Microsoft 
Office Excel will first perform computations in brackets/parentheses.  By inserting, the 10+10 in 
parentheses, Microsoft Office Excel will calculate the amount and then multiply the answer with 5, as 
multiplication is third in the sequence and after parentheses.  Your formula will change to (10+10)*5 = 
100 

 
In which order will Microsoft Office Excel perform this formula?  150 + 150 / (2 + 12) *12 / 4 = 182.14 

 
Sequence Formula Reason 
1st (2 + 12) = 14 Computations/calculations in parentheses/brackets, no matter 

where they are in the formula. 
2nd 150 /14 = 10.714  Computations involving multiplication (*) and division (/) from 

left to right.  The 14 relates to the answer calculated in the 1
st
 

sequence. 
3rd 10.714*12 = 128.568 Computations involving multiplication (*) and division (/) from 

left to right.  The 10.714 relates to the answer calculated in the 
2nd sequence. 

4th 128.568/4 = 32.142 Computations involving multiplication (*) and division (/) from 
left to right.  The 128.568 relates to the answer calculated in 
the 3rd sequence. 

5th 150+32.142=182.142 Computations involving addition and subtraction from left to 
right.  The 32.142 relates to the answer calculated in the 4th 
sequence. 

 
Look at the following examples.  Can you get to the same answer? 

 

100 + 100 / 2 = 150 (100+100)/2 = 100 

25 * 4 / 2 + 10 = 60 25 * 4 / (2 + 10) = 8.333 

150 + 150 / 2 + 12 * 12 / 4 = 261 (150 + 150) / 2 + 12 *12 / 4 =186 

(150 + 150) / (2 + 12) * 12 / 4 = 64.29  

 
1.3. Changing the sign of an amount: 
 

To change the sign of an amount from a positive to a negative, or alternatively from a negative to a 
positive, the amount can be multiplied by -1 for example +50 * -1 = -50 and -100 * -1 = +100 
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1.4. Percentages % 
 

If a whole cake is equal to 100% and you and your 4 friends need to share it equally, each one of you 
will get 20% of the cake.  How did we calculate it?  1 person/ 5 persons i.e. 1/5= 0.2 or 20% 

 
A percentage is a fraction where 1 equals the whole or 100%.  In Microsoft Office Excel and maths 
1=100% (100/100 = 1) and everything less than 1 (but more than 0) is a % thereof.  Please use the 
applicable fraction and not the % when working with percentages in Microsoft Office Excel.  Refer to the 
table below: 

 
% How to write it in Microsoft 

Office Excel 
33.33% 0.3333 
100% 1 
14% 0.14 

 
When you see a cell on a spreadsheet reflected as a percentage, please remember the underlying value 
of the cell is still a fraction.  The format of the cell (refer to paragraph 6.1.1 of TL103) was only changed 
to display the fraction as a percentage, but the underlying value did not change i.e. 50% underlying 
value in the cell is 0.50.  When you use a cell displaying a % format in any of your formulas/functions DO 
NOT multiply or divide the value with 100. 

 
1.5. Working with VAT% and Gross profit% 
 

You should be able to calculate amounts inclusive and exclusive of VAT as well as the VAT amount by 
using the applicable VAT percentage.  You should also be able to calculate sales amounts, cost of sales 
and gross profit and gross profit%.  You can use the following formula, or any other formula you are 
comfortable with, to help you with these calculations: 

 
The amount you need to calculate = the amount you need to calculate in percentage divided by 
the amount you have in percentage multiply with the amount you have in Rand 

 
EXAMPLE 1 – VAT 

 
 R % Microsoft Office Excel 

underlying value 
Selling price (excluding VAT) 500 100 1.00 
VAT 70 14 0.14 
Selling price (including VAT) 570 114 1.14 

 
Calculate the selling price excluding VAT using the selling price including VAT and the VAT% 

 
The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 1.00 (you need to calculate the selling price excluding VAT) 
o The amount you have in % = 1.14 (you have the selling price including VAT) 
o The amount you have in R = R570 (you have the selling price including VAT in Rand) 
o 1.00/1.14 * R570 = R500 

(Using math rules this formula can be simplified to: R570/1.14 = R500) 
 

Calculate the selling price including VAT using the selling price excluding VAT and the VAT% 
 

The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 1.14 (you need to calculate the selling price including VAT) 
o The amount you have in % = 1.00 (you have the selling price excluding VAT) 
o The amount you have in R = R500 (you have the selling price excluding VAT in Rand) 
o 1.14/1.00 * R500 = R570 

(Using math rules this formula can be simplified to: 1.14 * R500 = R570) 
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Calculate the VAT amount using the selling price including VAT and the VAT% 
 

The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 0.14 (you need to calculate the VAT amount) 
o The amount you have in % = 1.14 (you have the selling price including VAT) 
o The amount you have in R = R570 (you have the selling price including VAT in Rand) 
o 0.14/1.14 * R570 = R70 

 
Calculate the selling price including VAT using the VAT amount and the VAT% 

 
The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 1.14 (you need to calculate the selling price including VAT) 
o The amount you have in % = 0.14 (you have the VAT%) 
o The amount you have in R = R70 (you have the VAT amount in Rand) 
o 1.14/0.14 * R70 = R570 

 
GROSS PROFIT 
 

Basic Principles: 
• Gross profit = sales – cost of sales 
• Sales = cost of sales + gross profit 
• Gross profit% based on cost of sales = Gross profit / cost of sales 
• Gross profit% based on selling price = Gross profit / sales 

 
EXAMPLE 2 – Gross profit based on cost of sales 

 
The gross profit% (mark-up %), in this example, is 20% on cost of sales.  

 
 R % Microsoft Office Excel 

underlying value 
Cost of sales 1,580 100 1.00 
Gross profit 316 20 0.20 
Sales 1,896 120 1.20 

 
Calculate the cost of sales amount using the sales amount of R1,896 and the gross profit%. 

 
The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 1.00 (you need to calculate the cost of sales) 
o The amount you have in % = 1.20 (you have the sales) 
o The amount you have in R = R1,896 (you have the sales amount in Rand) 
o 1.00/1.20 * R1,896 = R1,580 

(Using math rules this formula can be simplified to: R1,896/1.20 = R1,580) 
 

Calculate the sales amount using the cost of sales amount of R1,580 and gross profit%. 
 

The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 1.20 (you need to calculate the sales amount) 
o The amount you have in % = 1.00 (you have the cost of sales) 
o The amount you have in R = R1,580 (you have the cost of sales amount in Rand) 
o 1.20/1.00 * R1,580 = R1,896 

(Using math rules this formula can be simplified to: R1,580 * 1.20 = R1,896) 
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Calculate the gross profit amount using the sales amount of R1,896 and gross profit%. 
 

The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 0.20 (you need to calculate the gross profit amount) 
o The amount you have in % = 1.20 (you have the sales) 
o The amount you have in R = R1,896 (you have the sales amount in Rand) 
o 0.20/1.20 * R1,896 = R316 

 
Calculate the sales amount using the gross profit amount of R316 and gross profit%. 

 
The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 1.20 (you need to calculate the sales amount) 
o The amount you have in % = 0.20 (you have the gross profit) 
o The amount you have in R = 316 (you have the gross profit amount in Rand) 
o 1.20/0.20 * 316 = R1,896 

 
EXAMPLE 3 – Gross profit based on selling price 

 
The gross profit% (mark-up %), in this example, is 20% based on sales. 

 
 R % Microsoft Office Excel 

underlying value 
Cost of sales 2,000 80 0.80 
Gross profit 500 20 0.20 
Sales 2,500 100 1.00 

 
Calculate the cost of sales amount using the sales amount of R2,500 and the gross profit%. 

 
The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 0.80 (you need to calculate the cost of sales) 
o The amount you have in % = 1.00 (you have the sales) 
o The amount you have in R = R2,500 (you have the sales amount in Rand) 
o 0.80/1.00 * R2,500 = R2,000 

(Using math rules this formula can be simplified to: 0.80 * R2,500 = R2,000) 
 

Calculate the sales amount using the cost of sales amount of R2,000 and gross profit% 
 

The amount you need in R = the amount you need in % / the amount you have in % X the amount 
you have in R 

 
o The amount you need in % = 1.00 (you need to calculate the sales amount) 
o The amount you have in % = 0.80 (you have the cost of sales) 
o The amount you have in R = R2,000 (you have the cost of sales amount in Rand) 
o 1.00/0.80 * R2,000 = R2,500 

(Using math rules this formula can be simplified to: R2,000/0.80 = R2,500) 
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2. HOW TO SOLVE A PROBLEM IN MICROSOFT OFFICE EXCEL 
 

Here are a few simple guidelines to keep in mind before you start with your spreadsheet: 
 

• Understand the business problem you are faced with.  What is the problem?  What should I 
calculate?  What is it based on?  Which amounts do I have?  What assumptions should I make? 

• How will you solve/fix the problem?  Formulate your desired results. 
• Plan your spreadsheet before you create it in Microsoft Office Excel. 
• Now go to Microsoft Office Excel and prepare the spreadsheet in such a manner it will give you the 

required output/deliverable. 
• Use neighbouring columns and rows when organising your information. 
• Do not skip columns or rows just because you want to “spread” the information, rather use the 

formatting functions. 
• Use a single column at the left of the table for row headings. 
• Use a single row at the top of the table for column headings. 
• If your table requires a title, put it in the row above the column heading and in the same column as 

the row heading. 
• Put all your assumptions/variables on the face of your spreadsheet.  As far as possible do not “hard 

code” any formulas i.e. entering an amount or percentage in a formula.  Rather refer to a cell where 
the amount or percentage is displayed. 

• Keep the spreadsheet logical. 
TIP: if you are struggling to write a formula using cell references, first write the formula using amounts 
and replace the amount with the relevant cell reference. 

 
3. BACKGROUND 
 
3.1. What is a spreadsheet  
 

A spreadsheet is a grid of columns and rows that crosses each other, much like a chessboard.  Columns 
appear vertically and are usually identified by a letter e.g. A, B, C, etc. while rows appear horizontally 
and are identified by a number 1, 2, 3, etc.  Where a column and a row intersect, a cell is formed.  Each 
cell has a unique address based on the specific column and row it can be found in.  A cell’s reference is 
always expressed as first the column reference and then the row reference.  Cell B6 will refer to a cell 
found where column B and row 6 intersect.  B6 is called a cell reference.  A cell address can never 
change but the data entered in a cell can change. 

 

 
 
 
  

Column B 

Cell B6 
(in column B and row 6) 

Cell A10 
(in column A and row 10) 

Row 6 
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3.2. Components/layout of a spreadsheet 
 

Refer to paragraph 7.4.4 in ISBE for an overview of the components of a spreadsheet window. 
 

When working in Microsoft Office Excel, you will begin using a workbook/file that contains screens called 
worksheets.  They are identified as Sheet1, Sheet2 and Sheet3.  Workbook or file means the same thing 
and you can use either when working with spreadsheets. 

 
The most recognisable difference between a word-processing document and a spreadsheet is that the 
spreadsheet uses rows and columns.  Numerical data entered into a spreadsheet is easier to read, 
understand and manipulate when presented in rows and columns. 

 
Below is a typical Microsoft Office Excel 2007 layout. 
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An Active cell, Ribbon, Dialogue box launcher, Office button and Quick access toolbar will now be 
explained in more detail. 

 
 
 
 
 
 

 
 
 
 
 
 
3.2.1. Active cell 

 
A cell becomes active when you select/click on that cell.  The active cell is outlined in black and the 
headings for the column and the row in which the cell is located are highlighted.  In the example above a 
cell in column B on row 2 was selected.  The headings on column B and row 2 are highlighted, and cell 
B2 is outlined.  The outlined cell and the highlighted column and row headings make it easier to see that 
cell B2 is the active cell.  The cell reference of the active cell (B2 in this example) will also appear in the 
Name Box in the upper-left corner of the worksheet. 

 
3.2.2. Ribbon 

 
The Ribbon is new to Microsoft Excel 2007 and has three basic components:  Tabs, Groups and 
Commands. 

 
• Tabs:  The seven tabs (Home, Insert, Page Layout, Formulas, Data, Review, View) each represent 

core tasks in Excel.  The commands on the Home tab are those Microsoft identified as the most 
common used when you do basic tasks in worksheets.  Tabs are similar to the Menu bar in Microsoft 
Excel 2003. 

• Groups:  Each tab has different groups that show related commands together.  Groups are similar to 
the different Toolbars in Microsoft Excel 2003. 

• Commands:  This is a button or a menu.  Commands are more commonly known as icons and each 
icon performs a particular function when you click on it with the mouse.  (Tip:  Hovering with your 
mouse pointer over an icon/command will make the description of the icon appear.) 

 
The commands on the Ribbon are the ones most used.  Excel 2007 shows some commands in 
response to an action you take instead of showing every command all the time.  For example, if there 
isn’t a chart in your worksheet, the commands to work with charts aren't visible.  But after a chart was 
created, the Chart Tools will appear, with three tabs:  Design, Layout, and Format.  When you complete 
the chart and click outside the chart area, the Chart Tools tabs go away.  To get the tabs back, click 
inside the chart and the tabs reappear. (Creating and editing charts will be explained in detail in 
paragraph 11 of TL103.) 
 
Don't worry if you don't see all the commands all the time, as the commands will appear as soon as 
you’ve taken the first step. 
 

 

Commands 

Groups 

Tab 

Dialog box 
launcher 

Office 
button 

Quick Access 
Toolbar 

Active cell 

Name Box: 
showing the 
Active cell 
address 
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3.2.3. Dialog Box Launcher  
 

When you see the Dialog Box Launcher arrow in the lower-right corner of a group, there are more 
options available for that group.  When you click on the arrow with your mouse it will open a dialog box 
or a task pane. 

 

3.2.4. Microsoft Office Button  
 

The Microsoft Office Button (Office Button) in the upper-left corner of the window will open a menu 
with commands used to open, save, print, send and close your workbooks/files.  The Excel Options 
button at the bottom of the menu will give you access to set options such as R1C1 reference style or 
showing the Formula Bar in the program window. 

 
3.2.5. Quick Access Toolbar 
 

The commands on the Quick Access Toolbar are always visible.  You can add commands you often use, 
to this toolbar by right-clicking on the command/icon you want to add and click on Add to Quick Access 
Toolbar.  To remove a button from that toolbar, right-click the button on the toolbar, and click Remove 
from Quick Access Toolbar. 

 
4. WORKBOOK BASICS 
 

We will now take you through various activities to help you understand workbook basics. 
 
4.1. Starting a workbook 
 

You will be able to start working with Microsoft Office Excel by following these steps: 
 

Activity 1: 
� Click on the Windows start icon 
� Select Programs 
� Select Microsoft Office 
� Select Microsoft Office Excel 2007 

 
OR 

 
� Select the Microsoft Office Excel icon from the desktop if visible 

 
The Microsoft Office Excel window with a full size workbook window will open.  The workbook will be 
displayed as discussed under the layout of the workbook.  The workbook will contain a file titled “Book 
1”. 

 
4.2. Saving a file 
 

Refer to paragraph 7.4.5.1 in the ISBE for how to save a file. 
 

Activity 2:  
� Click on the Office Button 
� Click on the arrow next to Save As 
� This will open the Save As menu options 

o Saving the workbook as an Excel Workbook, 
will save the file in Excel 2007 format.  
Selecting Excel 97-2003 Workbook will save 
the workbook in Excel 2003 format.  Please 
note that you’ll need to download a convertor to 
be able to open Excel 2007 formatted 
workbooks if you are using Excel 2003 on your 
computer. 

 
 

 



 
 

� Select Excel Workbook
This will open the Save As 
dialogue box 

� Beside Save In: select the 
folder where the 
workbook/file should be 
saved 

� Type the name of the file 
(“Test01”) into the file 
name text box which is 
beside File name. 

� Click the Save button 
 

 
 
 
 
 
4.3. Close a file and exit Microsoft Office Excel
 

Refer to 7.4.5.2 in ISBE for how to close a file and exit Microsoft Office Excel.
 
4.3.1. Only close the file you are working in while Microsoft Office Excel  is kept open

 
Activity 3: 
� Click on the Office Button
� Select Close 
� Select Yes to save the changes

 
4.3.2. Close the file as well as Microsoft Office Excel

 
Activity 4: 
� Click on the Office Button
� Select Exit Excel (lower-right corner)
� Select Yes to save the changes

 
Shortcut 
� Closing only the file – click on the X in the right hand corner of the tab bar
� Closing the file and Microsoft Office Excel 

 
 
 
 
 
 
 
Before you start the next section, start the Microsoft Office Excel Program and 
workbook file “Test01”. 
 
4.4. Naming/renaming worksheets
 

Refer to paragraph 7.4.5.3 in ISBE for inserting, naming and deleting worksheets.
 

Activity 5: 
� On the Sheet tab bar, right

sheet tab for Sheet1 
� Click on Rename. Sheet1

highlighted 
� Type the name “test” 
� Press Enter 

 
Shortcut 
� Double click on Sheet1 
� Type the name “test” 
� Press Enter 

14

cel Workbook.  
This will open the Save As 

select the 
folder where the 
workbook/file should be 

Type the name of the file 
(“Test01”) into the file 
name text box which is 

a file and exit Microsoft Office Excel 

Refer to 7.4.5.2 in ISBE for how to close a file and exit Microsoft Office Excel. 

Only close the file you are working in while Microsoft Office Excel  is kept open

Office Button 

to save the changes 

the file as well as Microsoft Office Excel 

Office Button 
right corner) 

to save the changes 

click on the X in the right hand corner of the tab bar 
file and Microsoft Office Excel – click on the X in the right hand corner of the title bar

Before you start the next section, start the Microsoft Office Excel Program and 

Naming/renaming worksheets 

in ISBE for inserting, naming and deleting worksheets.

On the Sheet tab bar, right-click on the 

Sheet1 will now be 

Close Microsoft Office Excel 
and workbook 

Only closes the workbook 

 

Only close the file you are working in while Microsoft Office Excel  is kept open 

click on the X in the right hand corner of the title bar 

Before you start the next section, start the Microsoft Office Excel Program and open the existing 

in ISBE for inserting, naming and deleting worksheets. 
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4.5. Inserting worksheets 
 

Activity 6: 
� Click on the Home tab 
� In the Cells group, click on the arrow next to Insert 
� On the drop-down menu click on Insert Sheet 

 

  
 

A new Worksheet will be added to your workbook called, Sheet4. 
 

Shortcut 
� Press Shift + F11 or 
� Click on the Insert worksheet icon 

 
 

 
4.6. Inserting columns or rows 
 

To insert a single column, click on any cell in the column immediately to the right of where you want the 
new column to be inserted and click on the applicable command. 

 
Activity 7: 
� On sheet test enter “Old column B” in cell B1 and “Old column C” in cell C1 
� Click on cell C2 
� Click on the Home tab 
� In the Cells group, click on the arrow next to Insert 
� On the drop-down menu click on Insert Sheet Columns 
� The spreadsheet will appear as follows: 

 

 
 

To insert a single row, click any cell in the row immediately below where you want the new row to be 
inserted and click on the applicable command. 

 
Activity 8: 
� On Sheet 2 enter “Old row 2” in cell A2 and “Old row 

3” in cell A3 
� Click on cell A3 
� Click on the Home tab  
� In the Cells group, click on the arrow next to Insert 
� On the drop-down menu click on Insert Sheet Rows 
� The spreadsheet will appear as follows: 

 
 

Insert worksheet 

New inserted column 

New inserted row 
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4.7. Deleting worksheets 
 

Activity 9: 
� Click on Sheet 3 (the worksheet you want to delete) 
� Click on the Home tab  
� In the Cells group, click on the arrow next to Delete 
� Click on Delete Sheet 

 
Sheet3 will be deleted. 

 
Shortcut 
� Click on the sheet you want to delete (Sheet 3 in this 

instance) 
� Right click and select Delete 

 
 
 
 
 
 
 
4.8. Deleting columns or rows 
 

To delete a single column, click on any cell in that column and click on the applicable command. 
 

Activity 10: 
� On sheet test click on cell C2 
� Click on the Home tab  
� In the Cells group, click on the arrow next to 

Delete 
� On the drop-down menu click on Delete Sheet 

Columns 
� The spreadsheet will appear as follows: 

 
To delete a single row, click on any cell in that row and click on the applicable command. 
 
Activity 11: 
� On sheet 2 click on cell A3 
� Click on the Home tab  
� In the Cells group, click on the arrow next to Delete 
� On the drop-down menu click on Delete Sheet Rows 
� The spreadsheet will appear as follows: 

 
 

 
4.9. Moving around in a spreadsheet 
 

Refer to paragraph 7.4.5.4 in ISBE for moving around in a spreadsheet. 
 

Except for using the mouse to move around in a spreadsheet the following keyboard keys can also be 
used: 

 
� CTRL + HOME Move the active cell to A1 
� CTRL + END Move the active cell to the last used cell (right bottom) in the worksheet 
� END + → Move to the last column 
� END + ↓ Move to the last row 
� Page Up Move one screen up 
� Page Down Move one screen down 
� F5 Specify the cell position to go to. 
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4.10. Selecting a worksheet range 
 

Refer to paragraph 7.4.5.5 in ISBE on how to select a worksheet range. 
 

Activity 12: 
� Anchor the Cell Pointer: 

o Click in Cell A1  
o Press and hold the Mouse button (left 

button) in Cell A1 
� Highlight the range A1:D4 

o While holding down the mouse 
button, drag across the Worksheet to 
Cell D4 

� Release the mouse button 
� The range address highlighted is A1:D4. 

 
 

 
5. OPERATING THE WORKBOOK 
 
5.1. Entering data 
 

Refer to paragraph 7.4.5.6 in ISBE for how to enter data. 
 
5.1.1. Entering numbers 
 

Activity 13: 
� Click in Cell A1 
� Enter the number “12345678” 
� Press Enter 

 
 

 
5.1.2. Entering text 
 

If the first character you enter is a letter, Microsoft Office Excel automatically proceeds the entry with a 
label-prefix character (‘).  If you want to enter numbers as a label, you should start your entry with a 
label-prefix character (‘). 

 
Activity 13 (continued): 
� Click in Cell A2 
� Enter the text “Spreadsheet” 
� Click in Cell B2 
� Enter the value “50 000” as a label 
� Press Enter 

 
 

 
5.2. Editing data 
 

Refer to paragraph 7.4.5.10 in ISBE for how to edit data.  Data can be corrected in two stages: 
 
5.2.1. Correcting errors while data is being entered 
 

Activity 14: 
� Click in Cell A5 
� Enter the text “DECENBER” (do not press Enter) 

 
You realize you have spelled the word DECEMBER incorrectly. 

 
� Click with the mouse pointer to the left of the character N 
� Press the Delete key 
� Type the character M 
� Confirm the entry by pressing Enter on the keyboard 
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5.2.2. Correcting errors after data has being entered 
 

Activity 15: 
� Click in Cell A6 
� Enter the text “DECENBER “ 
� Confirm the entry by pressing Enter on the keyboard 

 
You realize that you have spelled the word DECEMBER incorrectly. 

 
� Double click with the mouse pointer on the word or press F2 
� Click with the mouse pointer to the left of the character N 
� Press the Delete key 
� Type the character M 
� Confirm the entry by pressing Enter on the keyboard 

 
5.3. Removing data 
 

Refer to paragraph 7.4.5.11 in ISBE for how to remove data. 
 

Activity 16: 
� Click in Cell A1 
� Select range A1:J10 with the mouse 
� Press the Delete key 

 
5.4. Copying data 
 

Refer to paragraph 7.4.5.7 in ISBE for how to copy data. 
 

Activity 17: 
� Click in Cell A1 

� Type the data JANUARY 

� Click in cell A2 

� Type the data FEBRUARY 

� Select range A1:A2 with the mouse 

� Click on the Home tab 

� In the Clipboard group, click on Copy 

 
Note: The range contents will be placed on the CLIPBOARD, which is a temporary storage area. 

 
� Click on C1, the destination cell 

� Click on the Home tab 

� In the Clipboard group, click on Paste 

� The data is copied to the new destination and will appear as follows: 
 

 
 

Note: When you copy data, you will not remove the data from the cell, but merely make a copy.  The 
copy will be pasted at another location.  When the contents of the cell are pasted, it overwrites the 
existing cell contents where it is pasted. 

 
Shortcut 
� Copy: Press CTRL + C 
� Paste: Press CTRL + V 
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5.5. Moving of text 
 

Activity 18: 
� Select range A1:A2 with the mouse 

� Click on the Home tab 

� In the Clipboard group, click on Cut 

 
Note: The range contents will be placed on the CLIPBOARD, which is a temporary storage area. 

 
� Click on E1, the destination cell 

� Click on the Home tab  

� In the Clipboard group, 
click on Paste  

� The data is moved to the 
new destination and will 
look as follows: 

 
Note: When you cut data, you will remove the data from the cell and paste at another location.  When 
the contents of the cell are pasted, it overwrites the existing cell contents. 

 
Shortcut 
� Cut: Press CTRL + X 
� Paste: Press CTRL + V 

 
6. WORKBOOK & CELL FORMATTING 
 

Refer to paragraph 7.4.5.8 in ISBE for how to format data. 
 

Every time when a new file is created, the default setting is applicable.  If you exit the program and 
return to it, the settings in the dialog will be the default settings. 

 
6.1. Cell formatting 
 

The best way to understand how these settings work is to enter data in a range and see what happens if 
the settings in the dialog box are changed.  You can either use an icon (refer to paragraph 7.4.4 – 
Formatting toolbar in ISBE for description of some of these icons) on the Home tab in the Fonts, 
Alignment and Number groups or click on the Dialog Box Launcher  in one of these groups to open 
the Format Cells dialog box which appears as follow: 

 
 

Right clicking with your mouse on a cell 
and selecting Format Cells will also 
open the abovementioned dialog box. 

 
We will cover the more frequently used 
formatting options in section 6.1.1 to 
6.1.6 of this tutorial letter. 
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Activity 19: 
� Open a New Workbook 
� In cell A1 enter “Microsoft Excel 2007 Formats” 
� In cell A2 enter “JANUARY” 
� In cell A3 enter “Format cells”.  Do not change the column width to reflect the whole word. 
� In cell B2 enter 100000 
� In cell B3 enter 50000 
� In cell B5 enter 0.02 
� In cell B6 enter 2 
� In cell C2 enter 80000 
� In cell C3 enter 6500.54 

 
6.1.1. Number  formatting 
 

Use number format to differentiate one kind of numeric data from another for example, currency (R), 
percentage (%) etc.  There are a few different ways to get to the different menus needed. 

 
Activity 19 (continued): 
� Select cell B2 
� Click on the Home tab 
� In the Number group, click on Comma Style icon 

 
 

� Select cell B3 
� Click on the Home tab 
� In the Number group, click on the arrow next to the Accounting Number Format icon. In the drop-

down menu select R English (South African). 
� Select cell C2 
� Click on the Home tab 
� In the Number group, click on the Dialog Box Launcher arrow.  This will open the Format Cells 

dialog box. 
� Select the Number tab 
� Under Category select Number 
� Select 3 decimal places, tick the 1000 separator, and leave the negative numbers on the first option 

(-1,234.210). 
� Select OK to change the format 

 
� Select cell C3 
� Right click on your mouse and select Format Cells 
� Select the Number tab 
� Under Category select Currency 
� Under Symbol select $ English (US) 
� Select 1 decimal places and leave the negative numbers on the first option (-$1,234.1). 
� Select OK to change the format 

 
� Select cell B5 
� Click on the Home tab 
� In the Number group, click on Percent Style icon  

 
� Select cell B6 
� Click on the Home tab 
� In the Number group, click on the Dialog Box Launcher arrow.  This will open the Format Cells 

dialog box. 
� Select the Number tab 
� Under Category select Percentage 
� Select 2 decimal places 
� Click on OK 
� Does cell B5 or B6 reflects 2% after the % format was applied to it? 
� Cell B5 which value was entered as 0.02. 

 
It is VERY important to remember that the underlying value of a cell formatted as a % is a fraction 
i.e. the underlying value of cell B5 is 0.02 and not 2 and the underlying value of cell B6 is 2 and 
not 200 in Microsoft Office Excel.  Please refer to paragraph 1.4 of TL103. 
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6.1.2. Alignment of data 
 

This will give you options regarding Text Alignment, Text Control and Text direction. 
 

Activity 19 (continued): 
� Select range A1:C1 
� Click on the Home tab 
� In the Alignment group, click on the arrow next to the Merge & Centre 
� On the drop-down menu select Merge & Centre 
� Merge combines the selected cells into 1 cell 
 
� Select range A2:A3 
� Click on the Home tab 
� In the Alignment group, click on the Wrap text icon 

 
6.1.3. To change fonts and attributes 
 

Under the Font tab, you will find the following default settings for the workbook:  (This may differ from 
your default) 

 
• Font name: Arial 
• Font style: Regular 
• Size: 10 
• Colour: Automatic 
• Underline: None 

 
Under this tab, you can change any of the above-mentioned settings and also add bold, italics and 
underlining to the text. 

 
Activity 19 (continued): 
� Select cell A1 
� Click on the Home tab 
� In the Font group, click on the arrow next to the Font icon 
� On the drop-down menu select Comic Sans MS 
� In the Font group, click on the arrow next to the Font size icon 
� On the drop-down menu select 12 
� In the Font group, click on the Bold icon 

 
� Select range A2:C6 
� In the Font group, click on the Dialog Box Launcher arrow.  This will open the Format Cells dialog 

box. 
� Select the Font tab 
� Under Font select Arial 
� Under Size select 11 
� Select OK to change the format 
 

6.1.4. Borders 
 

You can frame the data with borderlines and different edges. 
 

Activity 19 (continued): 
� Select cell B3 
� Click on the Home tab  
� In the Font group, click on the arrow next to the Border icon 
� On the drop-down menu select the Bottom Double Border icon 

 
� Select cell C3 
� Click on the Home tab 
� In the Font group, click on the arrow next to the Border icon 
� On the drop-down menu select the Top and Double Bottom Border 

icon 
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6.1.5. Fill 
 

Here you can set the background colour and pattern of the cells selected.  (Do not change any for this 
Activity) 

 
6.1.6. Protection 
 

Here you can lock cells so that it cannot be changed when a worksheet is protected.  (Do not change 
any for this Activity) 

 
Activity 19 (continued): 
� Your results for Activity 19 should appear as follow: 

 

 
 
 
6.2. Column width 
 

The column width should be set to fit the largest set of characters in a cell.  If you see the following in a 
cell ######## (hashers), it means the column width is too small. 

 

 
 

There are two ways of correcting this problem: 
 

• Using an icon/command: 
o Click on the Home tab 
o In the Cells group, click on the arrow next to the Format icon 
o On the drop-down menu select Column Width and set the column 

width until the data appears, or 
 

• Using the mouse: 
o Move the mouse pointer to the letter “B” of the column header 
o Point to the right of the column border 
o The mouse pointer changes to a black two headed vertical arrow 
o Click the mouse and drag to the right to set the width of the column, or 
o If you double click the mouse, the width will be set to fit the largest 

data cell 
 

The data will be displayed. 
 

 
 
6.3. Row height 
 

The row height should be set to fit the largest set of characters in a cell.  If you cannot see all the text in 
a cell, it means the row height is too small. 
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There are two ways of correcting this problem: 
 

• Using an icon/command: 
o Click on the Home tab 
o In the Cells group, click on the arrow next to the Format icon 
o On the drop-down menu select Row Height and set the row height until the data appears, or 

 
• Using the mouse: 

o Move the mouse pointer to the number “1” of the row header 
o Point to the bottom of the row border 
o The mouse pointer changes to a black two headed horizontal arrow 
o Click the mouse and drag down to set the width of the column 

 
The data will then be displayed. 

 
 
7. PRINTING & PAGE LAYOUT 
 

Refer to paragraph 7.4.5.9 in ISBE on how to print. 
 

 
 
7.1. Print area 
 

This defines/selects which area of a worksheet you want to print.  Always define the area you want to 
print before you continue with the rest of the page setup (refer to paragraph 7.2 of TL103). 

 
Activity 20: 
� Select the area you want to print 
� Click on the Page Layout tab 
� In the Page Setup group, click on the arrow next to the Print Area icon 
� On the drop-down menu select Set Print Area 

 
7.2. Page setup 
 

Setting the layout of a worksheet that needs to be printed can be set by either: 
 

� Using the applicable tab and 
icon on the Ribbon or 

� Using the Page set-up dialog 
box by clicking on the Dialog 
Box Launcher arrow in the 
Page Setup group on the 
Page Layout tab. 

� Page set-up dialog box will 
appear as follow: 
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7.2.1. Page 
 

• Orientation 
Orientation is used to set whether you want to print the printed worksheet in a portrait or landscape 
format. 

 

Ribbon: 

Page Layout tab 

Dialog Box Launcher: 

Page set-up dialog box 

o Click on the Page Layout tab  

o In the Page Setup group, 
click on the arrow next to the 
Orientation icon 

o On the drop-down menu 
select either Portrait or 
Landscape 

o Select the Page tab in the Page set-up 
dialog box 

o Click on either Portrait or Landscape 

 
o Leave the default selection 

 
• Scaling 

Scaling is used to set the width or height of a printed worksheet to a maximum number of pages or to 
stretch or shrink the printed worksheet to a percentage of its actual size. 

 

Ribbon: 

Page Layout tab 

Dialog Box Launcher: 

Page set-up dialog box 

o Click on the Page Layout 
tab 

o In the Scale to Fit group: 

� By clicking on the 
arrow next to Scale 
you can increase or 
decrease the size in 
relation to the normal size 

� By clicking on the arrow next to Width you can 
define over how many pages wide you want to 
print the selected area 

� By clicking on the arrow next to Height you can 
define over how many pages tall you want to 
print the selected area 

o Select the Page tab in the Page set-
up dialog box 

o By selecting “Adjust to” you can 
stretch or shrink the printed worksheet 
to a percentage of its actual size 

o By selecting “Fit to” you can reduce 
the width and/or the height of the 
printed worksheet to fit a maximum 
number of pages wide and/or tall.  For 
example if you set both wide and tall to 
1 your selected print area will print the 
print area set in par 7.1 of TL103 to 
one page only. 

 
o Leave the default selection  

 
• Paper size 

Select the size of paper you are printing to. 
 

Ribbon: 

Page Layout tab 

Dialog Box Launcher: 

Page set-up dialog box 

o Click on the Page Layout tab 

o In the Page Setup group, click on the arrow next to 
the Size icon 

o On the drop-down menu select the applicable paper 
size 

o Select the Page tab in the Page set-
up dialog box 

o Select the applicable paper size from 
the drop-down menu 

 
o Select A4  
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7.2.2. Margins 
 

Here you can change the margin size of the printed worksheet. 
 

Ribbon: 

Page Layout tab 

Dialog Box Launcher: 

Page set-up dialog box 

o Click on the Page Layout tab 

o In the Page Setup group, click on the arrow next to 
the Margin icon 

o On the drop-down menu select the applicable 
margins or select Custom Margins to open the 
Page set-up dialog box 

o Select the Margins tab in the Page 
set-up dialog box 

o Increase or decrease the margins to 
the required size 

 
o Select Normal margins 

 

7.2.3. Header/footer 
 

Headers or footers can be included to provide useful information in your worksheet printouts such as 
page numbers, the date and time, and the file name or other predefined information. 

 

Ribbon: 

Insert tab 

Dialog Box Launcher: 

Page set-up dialog box 

o Click on the Insert tab  

o In the Text group, click on the Header & Footer icon 

o Click the left, centre, or right header or footer text box 
at the top or at the bottom of the worksheet page.  

o Type the text you want 

o Clicking on any of the text boxes will display the 
Design tab. 

o On the Design tab, in the Header & Footer Elements 
group, click the element that you want to include 

o Select the Header/Footer tab in the 
Page set-up dialog box  

o Include the applicable Header and 
or Footer 

 

o Include your name as a Header 
 

 
 

o Include the page number 
as a Footer by clicking 
on Page number icon on 
the Design tab, in the 
Header & Footer 
Elements group 

 
 
 
 
 
 

 
 

  
To return to Normal view, click on the View tab, in the Workbook Views group, click on the 

Normal icon. 
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7.2.4. Sheet (Gridlines and Row & Column headings) 
 

Gridlines, row headings (1, 2, 3, etc) and column headings (A, B, C, etc) are displayed by default in 
Page Layout view, but they are not printed automatically when printing a worksheet.  To print the 
gridlines and/or row and column headings do the following: 

 

Ribbon: 

Page Layout tab 

Dialog Box Launcher: 

Page set-up dialog box 

o Click on the Page Layout 
tab 

o In the Sheet Options group 

o Tick Print under Gridlines to 
print gridlines 

o Tick Print under Headings 
to print Row and column 
headings 

o Select the Sheet tab in the Page set-
up dialog box 

o Under Print 

� Click on Gridlines to print gridlines 

� Click on Row and column 
headings to print the headings 

 
 
7.3. Print & Print preview 
 

Activity 20 (continued): 
� Click on the Office Button 
� Select Print 
� Select Print Preview 

o In this view you will see how your 
worksheet will look like when it’s 
printed on paper 

o Select Close Print Preview to close 
the window and return to your 
worksheet 

 
 
 
 

Activity 20 (continued): 
� Click on the Office Button 
� Select Print 
� The Print dialog box will appear, with the following options: 

 

 
 

• “Printer” 
o To which printer do you want to print your document 
o Leave the default selection 
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• “Print range” 
o Define if you want to print everything (All) or just certain pages (Pages: From – To) 
o Leave the default selection 
 

• “Copies” 
o Set the number of copies you want to print 
 

•  “Print what” 
o Active Sheet (Print the sheet which is displayed) 
o Entire workbook (Print all the sheets in the file) 
o Select selection (Print the range you have selected) 
 

• Select the Preview button to see the print online, or 
• Select OK to print 

 
 
8. WORKING WITH FORMULAS 
 

Refer to paragraph 7.4.6 in ISBE on how to work with formulas. 

 
8.1. Common errors when using formulas and functions 
 

Once an error shows up in a cell, you have to find the cause of the error and edit the worksheet to 
correct the error.  Below are common errors displays found in Microsoft Office Excel and the reasons for 
it: 

 
#DIV/0! 
This error occurs when the formula calls for division by a cell that either contains the value 0 or, as is 
more often the case, is empty.  Division by zero is a not possible according to maths. 

 
#NAME? 
This error occurs when Microsoft Office Excel doesn't recognize text in a formula. 

 
#NULL! 
This error occurs most often when you insert a space where you should have used a comma to separate 
cell references used as arguments for functions. 

 
#NUM! 
This error occurs when Microsoft Office Excel encounters a problem with a number in the formula, such 
as the wrong type of argument in a Microsoft Office Excel function or a calculation that produces a 
number too large or too small to be represented in the worksheet. 

 
#REF! 
This error occurs when Microsoft Office Excel encounters an invalid cell reference, such as when you 
delete a cell referred to in a formula or paste cells over cells referred to in a formula. 

 
#VALUE! 
Appears when you use the wrong type of argument in a function, the wrong type of operator, or when 
you call for a mathematical operation that refers to cells that contain text entries. 

 
#N/A! 
This error occurs when a value is not available to a function or a formula. 

 
 
 
 
 
 
 
 
 
 

A formula in Microsoft Office Excel always start with an = sign! 
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8.2. Entering formulas 
 
8.2.1. Adding, subtracting, dividing and multiplying values 
 

Activity 21: 
� Open a new workbook/file 
� Rename worksheet “Sheet 1” to Practice 
� Click on cell A1 in worksheet “Practice” 
� Type the value 100 and Enter 
� Click on cell A2 
� Type the value 20 and Enter 

 
Add the two values together in cell A3.  The answer of adding the 2 cells will be displayed in cell A3. 

 
Activity 21 (continued): 
� Click on cell A3 (chosen for the formula) 
� Enter = to begin the formula 
� Enter the first operand (cell A1) by using the arrow key or by clicking on the cell with the mouse 
� Enter the first operator ( + ) 
� Enter the next operand (cell A2) by using the arrow key or by clicking on the cell with the mouse 
� Press Enter 
� The answer that appears is 120 

 
Repeat the above Activity, but instead of adding the two values, now subtract them from each other in 
cell A4, multiply the 2 values in cell A5 and divide the two values by each other in cell A6. 

 
This can be achieved by merely changing the operator every time, but keeping the same format of 
operations i.e. using cell A1 as first operand and cell A2 as second operand.  The answer should look 
like this: 

 

   
 
 
8.2.2. Adding values in two separate worksheets 
 

Activity 22: 
� Rename worksheet “Sheet2” to Test 
� Click on cell A1 in worksheet “Test” 
� Type the value 200 and Enter 
� Click on cell A2 
� Type the value 40 and Enter. 

 
� Click on cell A3 in worksheet “Test” (chosen for the formula) 
� Enter = to begin the formula 
� Enter the first operand (sheet Test cell A1) by using the arrow key 
� Enter the first operator ( + ) 
� Enter the next operand (sheet Test cell A2) by using the arrow key 
� Enter the second operator ( + ) 
� Click on sheet tab “Practice” 
� Click on cell A1 in worksheet “Practice” 
� Enter the third operator ( + ) 
� Click on cell A2 in worksheet “Practice” 
� Press Enter 
� The answer that appears is 360 

 
The formula in cell A3 on sheet “Test” will be: 
=A1+A2+Practice!A1+Practice!A2 
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8.2.3. Combing text and values (&) 
 

Using “&” will reflect the contents of the cells/value/text combined beside each other e.g. =2000&100 will 
reflect as 2000100.  Spaces and other symbols can be added by inserting it in the formula using quotes 
e.g. =2000&“-”100 will reflect as 2000-100. 

 
Activity 23: 
� Rename worksheet “Sheet3” to Add 
� Enter the following data in the worksheet 

 
 
 
 
 
 
 

� In cell C1 enter =A1&A2 and in cell C2 enter =A2&B2. 
o Observe the results displayed in cell C1 (NissanHardbody) and in cell C2 (198512). 
o Note using “&” in the formula in cell C2 did not sum the two values but display the values beside 

each other. 
� In cell C3 enter =A3&“ ”&A3 and in cell C4 enter =A4&“-”&B4. 

o Observe the results displayed in cell C3 (Toyota Corolla) and in cell C4 (Ford-200) 
o Note using “ ” inserted a space in the displayed answer (C3) while inserting “-” included a dash in 

the displayed answer (C4) 
� The answer should appear as follow: 

 

   
 
8.3. Copying formulas 
 
8.3.1. Relative reference 
 

Where the column and row reference of a cell reference in a formula changes when copied down 
and/or across, the cell address is referred to as being a relative reference. 

 
A formula or a function can be copied by using the steps in paragraph 5.4 of TL103 or by the following: 
• Click on the cell where the formula is which you want to copy. 
• With your mouse pointer stand on the right-hand bottom corner of the cell until the mouse pointer 

turns to a black cross. 
• Click and drag the formula down or across to the cells you want to copy the formula to and release 

the mouse button. 
 
8.3.1.1. Copy down 
 

When a formula is copied down (over rows) in a spreadsheet, the cell’s row reference will increase with 
the number of rows the formula is copied down with e.g. 
• a formula  =A1*B1 copied down 1 row will change to =A2*B2 i.e. cell A1 + 1row = cell A2 and cell B1 

+ 1row = cell B2 
• a formula  =A1*B1 copied down 3 rows will change to =A4*B4 i.e. cell A1 + 3rows = cell A4 and cell 

B1 + 3rows = cell B4 
 
 
 
 
 
 
 
 
 

 A B C 
1 Nissan Hardbody  
2 1985 12  
3 Toyota Corolla  
4 Ford 200  

 A B 
1   
2   
3   
4   
5   

Number of rows copied 
down (3 rows) 
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Activity 24: 
� Enter the following data into a spreadsheet: 

 
 
 
 
 
 
 
 

� In cell D2 calculate the total price for shoes by entering the formula =B2*C2 
� Copy the formula in cell D2 to cells D3, D4 and D5 
� What happened to the formula in cell D3?  Is it still =B2*C2 or did it change? 

o The row reference in the cell reference increased with the number of rows the formula was copied 
down with i.e. 1.  Cell B2 + 1row = cell B3 and cell C2 + 1row = cell C3.  The formula therefore 
changed from =B2*C2 to =B3*C3. 

� What happened with the formula in cell D5?  Is it still =B2*C2 or did it change? 
o The row reference in the cell reference increased with the number of rows the formula was copied 

down with i.e. 3 rows.  Cell B2 + 3rows = cell B5 and cell C2 + 3rows = cell C5.  The formula 
therefore changed from =B2*C2 to =B5*C5. 

 
� The answer should appear as follows: 

 

  
 
8.3.1.2. Copy across 
 

When a formula is copied across (over columns) in a spreadsheet the cell’s column reference will 
increase with the number of columns the formula is copied across with e.g. 
• a formula  =A1+A2 copied across 1 column will change to =B1+B2 i.e. cell A1 + 1column = cell B1 

and cell A2 + 1column =  cell B2. 
• a formula of =A1+A2 copied across 3 columns will change to =D1+D2  i.e. cell A1 + 3columns = cell 

D1 and cell A2 + 3columns =  cell D2. 
 
 
 
 
 
 
 

Activity 25: 
� Enter the following data into a spreadsheet: 

 
 
 
 
 
 
 

� In cell B4 calculate the total for March by entering the formula =B2+B3 
� Copy the formula in cell B4 to cells C4, D4 and E4 
� What happened with the formula in cell C4?  Is it still =B2+B3 or did it change? 

o The column reference in the cell reference was increased with the number of columns the 
formula was copied across with i.e. 1.  Cell B2 + 1column = cell C2 and cell B3 + 1column = cell 
C3.  The formula therefore changed from =B2+B3 to =C2+C3. 

 
 
 

 A B C D 
1  Number of items Price per item Total Price 
2 Shoes 6 5  
3 T-shirts 4 15  
4 Jackets 2 20  
5 Jeans 5 18  

 A B C D E 
      
      

 A B C D E 
1  March April May  June 
2 Shoes 500 1005 580 730 
3 T-shirts 700 650 408 840 
4 Total     

Number of columns copied across 
(3 columns) 
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� What happened with the formula in cell E4?  Is it still =B2+B3 or did it change?  
o The column reference in the cell reference was increased with the number of columns the 

formula was copied across with i.e. 3 columns.  Cell B2 + 3columns = cell E2 and cell B3 + 
3columns = cell E3.  The formula therefore changed from =B2+B3 to =E2+E3. 

� The answer should appear as follows: 
 

   
 
 

8.3.1.3. Copy across & down 
 

Activity 26: 
� Enter the following data into a spreadsheet: 

 

 A B C 
1 Number sold January February 
2 Shoes 20 25 
3 T-shirts 50 80 
4 Jackets 35 32 
5 Jeans 60 70 
6    
7 Selling price per item January February 
8 Shoes 100 100 
9 T-shirts 50 55 
10 Jackets 300 310 
11 Jeans 150 100 
12    
13 Total sales per item January February 
14 Shoes   
15 T-shirts   
16 Jackets   
17 Jeans   

 
� Calculate the total sales per item by multiplying the number sold with the price of the item. 
� Calculate in cell B14 the total sales for Shoes sold in January by entering the formula =B2*B8 
� Copy the formula in cell B14 to cells B15, B16 and B17. 
� What happened with the formula in cell B16?  Is it still =B2*B8 or did it change? 

o The row reference in the cell reference increased with the number of rows the formula was copied 
down i.e. 2 rows.  Cell B2 + 2rows = cell B4 and cell B8 + 2rows = cell B10.  The formula therefore 
changed from =B2*B8 to =B4*B10. 

� The answer should appear as follows: 
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� Copy the formula in cell B14 to cells C14, C15, C16 and C17. 
� What happened with the formula in cell C14?  Is it still =B2*B8 or did it change? 

o The column reference in the cell reference increased with the number of columns the formula 
was copied across i.e.1 column.  Cell B2+1column = cell C2 and cell B8 + 1column = cell C8.  
The formula therefore changed from =B2*B8 to =C2*C8. 

� What happened to the formula in cell C17?  Is it still =B2*B8 or did it change? 
o Not only was the column reference in the cell reference increased with the number of columns 

the formula was copied across (1 column) but the row reference was also increased with the 
number of rows the formula was copied down (3 rows).  The formula therefore changed from 
=B2*B8 to =C5*C11 i.e. 

� cell B2 + 1column + 3rows = C5 
� cell B8 + 1column + 3rows = C11 

� The answer should appear as follows: 
 

  
 
8.3.2. Absolute reference 
 

In contrast with a relative reference, (refer to paragraph 8.3.1 of TL103) the column and/or row reference 
in an absolute reference is “fixed” and does not change when a formula is copied down and/or across.  
Inserting a $ in front of the row or/and column reference will make the reference absolute.  Inserting a 
dollar sign ($) in front of a column or a row will ensure the column or row reference is absolute (“fixed”) 
and will not change when the formula is copied across or down.  There are 3 types of absolute 
references: 
• Absolute row reference - Insert the $ in front of the row reference only e.g. B$5.  When copied only 

the column reference (B) will change but the row reference (5) is fixed and will not change.  Refer to 
paragraph 8.3.2.1 of TL103. 

• Absolute column reference - Insert the $ in front of the column reference only e.g. $B5.  When 
copied only the row reference (5) will change but the column reference (B) is fixed and will not 
change.  Refer to paragraph 8.3.2.2 of TL103. 

• Absolute column and row reference - Insert the $ in front of both the column and row reference 
e.g. $B$5.  When copied both the column reference (B) and the row reference (5) is fixed and will not 
change.  Refer to paragraph 8.3.2.3 of TL103. 

 
The $ can be inserted by: 
• changing your formula to include the $ or 

• highlight the cell reference in the formula/function and press the F4 function key until the $ is 
displayed.  Each time the F4 key is pressed it will change where the $ is displayed i.e. in front of both 
the column and row reference, in front if the row reference only or in front of the column reference 
only. 
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8.3.2.1. Absolute row reference e.g. B$5 
 

Activity 27: 
� Enter the following data into a spreadsheet: 

 
 A B C 

1 VAT Rate 14%  
2    
3  Sales excluding VAT Sales including VAT 
4 January 1500  
5 February 1200  
6 March 1300  
7 April 500  
8 May 800  
9 June 1400  

 
� Calculate the sales amount, per month, including VAT by using the provided VAT%.  The formula will 

be entered once and copied to the rest of the cells.  What formula will you enter in cell C4? 
� In cell C4 enter =(B4*B1)+B4 i.e. sales including VAT = (sales excluding VAT x VAT) + sales 

excluding VAT. 
� Copy the formula in cell C4 to cell C5 and observe how the formula changes.  As explained in 

paragraph 8.3.1.1 of TL103 relative row references, in a formula, will increase with the number of 
rows the formula is copied down i.e. the formula will change from =(B4*B1)+B4 to =(B5*B2)+B5. 
o However, we did not want cell reference B1, in the formula, to change to B2 because the VAT% 

was entered in cell B1. 
o How do you think cell reference B1 should change to ensure, when copied down, it still refers to 

cell B1 and will not change?  The row reference should be made absolute (fixed) by inserting a $ 
sign in front of the row reference (B$1). 

� Delete the formula copied to cell C5. 
� In cell C4 change cell reference B1 to include the applicable absolute reference i.e. =(B4*B$1)+B4. 
� Now copy the formula to range C5:C9 and observe how the formula changes. 
� What happened with the formula in cell C6?  How did it change? 

o The row reference of the relative cell reference changed as explained in 8.3.1.1 of TL103 (B4 to 
B6).  However, the row reference in B$1 did not change, as it was absolute/fixed.  The formula 
therefore changed from =(B4*B$1)+B4 to =(B6*B$1)+B6. 

� The answer should appear as follows: 
 

   
 

Please note when the VAT rate was entered into the spreadsheet it was entered as 0.14 and the 
format of the cell changed to display a % format.  The format of the numbers was changed to 
number format with 2 decimals.  Refer to paragraph 6.1.1 of TL103. 
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8.3.2.2. Absolute column reference e.g. $B5 
 

Activity 28: 
� Enter the following data into a spreadsheet: 

 
 A B C D E F G H 
1 VAT rate 14%       
2         
3  January February March April May June July 
4 Sales Excl Vat  1,500.00   1,200.00   1,300.00  500.00  800.00  1,400.00  900.00  
5 Sales Incl Vat        

 
� Calculate the sales amount, per month, including VAT by using the provided VAT%.  The formula will 

be entered once and copied to the rest of the cells.  What formula will you enter in cell B5? 
� In cell B5 enter =(B4*B1)+B4   
� Copy the formula to cell C5 and observe the change in the formula.  As explained in paragraph 

8.3.1.2 of TL103 relative column references, in a formula, will increase with the number of columns 
the formula is copied across i.e. the formula will change from =(B4*B1)+B4 to =(C4*C1)+C4. 
o However, we did not want cell reference B1, in the formula, to change to C1 because the VAT% 

was only entered in cell B1. 
o How do you think cell reference B1 should change to ensure, when copied across, it still refers to 

cell B1 and will not change?  The column reference should be made absolute (fixed) by inserting a 
$ sign in front of the column reference ($B1). 

� Delete the formula you have copied to cell C5. 
� In cell B5 change cell reference B1 to include the applicable absolute reference i.e. to =(B4*$B1)+B4 
� Now copy the formula to range C5:H5 and observe how the formula changes. 
� What happened with the formula in cell E5?  How did it change? 

o The column reference of the relative cell references changed as explained in 8.3.1.2 of TL103 (B4 
to E4).  However, the column reference in $B1 did not change, as it was absolute/fixed.  The 
formula therefore changed from =(B4*$B1)+B4 to =(E4*$B1)+E4 

� The answer should appear as follows: 
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8.3.2.3. Absolute column and row references e.g. $B$5 
 

Activity 29: 
� Enter the following data into a spreadsheet: 

 
 A B C D E 

1 VAT rate 14%    
2      
3 Sales Excl Vat January February March April 
4 Shoes 2,000.00  2,500.00  3,000.00  2,900.00  
5 T-shirts     500.00      800.00     700.00     400.00  
6 Jackets  3,500.00   3,200.00  3,800.00  4,000.00  
7 Jeans  6,000.00   7,000.00  4,000.00  3,000.00  
8 Hats     150.00      200.00     300.00     250.00  
9      

10      
11 Sales incl Vat January February March April 
12 Shoes     
13 T-shirts     
14 Jackets     
15 Jeans     
16 Hats     

 
� Calculate the sales amount, per month, including VAT by using the provided VAT%.  The formula will 

be entered once and copied to the rest of the cells.  What formula will you enter? 
� In cell B12 enter =(B4*B1)+B4 . 
� Copy the formula to cell D15 and observe how the formula changes.  As explained in paragraph 

8.3.1.3 of TL103 relative column and row references, in a formula, will increase with the number of 
columns/rows the formula is copied across/down.  The formula will change from =(B4*B1)+B4 to 
=(D7*D4)+D7. 
o However, we did not want cell reference B1, in the formula, to change to D4 because the VAT% 

was entered in cell B1. 
o How do you think cell reference B1 should change to ensure, when copied across and down, it 

still refers to cell B1 and will not change?  The column and the row reference should be made 
absolute (fixed) by inserting a $ sign in front of the column and row reference ($B$1). 

� Delete the formula you have copied to cell D15. 
� In cell B12 change cells reference B1 to include the applicable absolute references i.e. 

=(B4*$B$1)+B4 
� Now copy the formula to range B13:B16 and range C12:E16 and observe how the formula changes. 
� What happened with the formula in cell D15?  How did it change? 
� The column and row references of the relative cell references changed as explained in 8.3.1.3 of 

TL103 (B4 to D7).  However, the column and row reference in $B$1 did not change, as it was 
absolute/fixed.  The formula therefore changed from =(B4*B1)+B4 to =(D7*$B$1)+D7. 

� The answer should appear as follows: 
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9. FUNCTIONS 
 

Refer to paragraph 7.4.7.1 - 7.4.7.3 in ISBE for how to work with functions. 
 

A function is a short cut to make calculations easier and quicker.  Functions should always be used if 
available. 

 
9.1. Structure of a function 
 

A function ALWAYS begins with an equal sign (=), followed by the function name, the opening 
parenthesis, the arguments for the function separated by commas and the closing parenthesis. 

 
Let us break the following examples down in the above-mentioned structure. 

 
=sum(cell1:cell2) 
Structure The formula 
Begins with = sign = 
Function name sum 
Opening parenthesis ( 
The arguments for the function  cell1:cell2 
Closing parenthesis ) 

 
=PMT(rate,nper,pv,fv,type) 
Structure The formula 
Begins with = sign = 
Function name PMT 
Opening parenthesis ( 
The arguments for the function separated by commas rate,nper,pv,fv,type 
Closing parenthesis ) 

 
=IF(Logical_test,value_if_true,value_if_false) 
Structure The formula 
Begins with = sign = 
Function name IF 
Opening parenthesis ( 
The arguments for the function separated by commas Logical_test,value_if_true,value_if_fa

lse 
Closing parenthesis ) 
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9.2. Reference operators – when to use : or , 
 
9.2.1. Colon : 
 

A colon ( : ) is used to select all the cells from and including the 1
st
 cell reference to and including the 

last cell reference.  A1:A9 will therefore include all the cells from and including A1 to A9.  (see the 
highlighted cells below). 

 

 
 
 
9.2.2. Comma , 
 

A comma ( , ) is used if you want to select specified cells and is placed between each cell reference.  
A1,A4,A6 will therefore only include/select only cells A1, A4 and A6.  (see highlighted cells below) 

 

 
 

A comma is also used to separate the arguments of a function e.g. 
=IF(condition,value_if_true,value_if_false) 

 
9.2.3. Combining a colon : and a comma , 
 

A comma (,) and a colon (:) can be combined.  This is used when combining 2 different ranges for 
example A1:A3,A6:A8 will select/include cells A1, A2, A3, A6, A7 and A8.  (see highlighted cells below) 

 

 
 
  

Include all the 
cells 

Only include 
the highlighted 

cells 

Include both 
the highlighted 

cell ranges 
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9.3. Insert a function 
 

Activity 30: 
� Click on the Formulas tab 
� Click on the fx insert function icon 
� At “Or select a category” choose  All 
� The dialog box will now display as follows: 

 
 
 

 
 

Note: By changing the Category the = Functions for that specific category will be displayed in the 
Select a function box.  By clicking on the Function a description appears at the bottom of the dialog 
box, explaining the operation of the command. 

 
9.4. Commonly used functions 
 

Here are some examples of commonly used functions in the financial environment: 
 
9.4.1. Mathematical functions 
 

Please note cell1 refers to the first cell in the range and cell2 to the last cell in the range and cell11, 
cell12, cell13 refers to selected cells.  Refer to paragraph 9.2 of TL103 for the difference in using a 
comma or colon. 

 
  

Formulas tab 

fx insert 
function icon 
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9.4.1.1. SUM 
 

This function adds values in individual cells or cells ranges together. 
 

=SUM(cell1:cell2) 
Adds all the values in a specified range of cells 

 
=SUM(cell11,cell12,cell13) 
Adds all the values for specified cells 

 
Activity 31: 
� Create a worksheet and enter the following data 

 
 A B 
1 T-shirts in stock per different type of T-shirt  
2   
3 Type of sport T-shirt Number of T-shirt 
4 Soccer 125 
5 Rugby 77 
6 Swimming 65 
7 Cricket 45 
8 Tennis 89 
9 Netball 36 

10 Basketball 25 
11 Hockey 50 
12 Athletics 95 
13 Table tennis 16 

 
� In cell B14 calculate the total number of T-shirts for all the types of T-shirts. 
� In cell B16 calculate the total number of T-shirts for the swimming, netball and hockey T-shirts 

only. 
� In cell B18 calculate the total number of T-shirts for the rugby, swimming, cricket, hockey and 

athletic T-shirts only. 
� The answer should appear as follows: 
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9.4.1.2. ROUND 
 

This function rounds the value in the specified cell to the specified number of digits. 
 

=ROUND(cell1,number_of_digits) 
 

Cell1 refers to cell that will be rounded.  Number_of_digits refer to the number of digits the answer 
should be rounded to. 

 
Activity 32: 
� Use the data entered in Activity 31. 
� In column C divide the number of T-shirts for soccer, swimming, basketball, and table tennis by 3. 
� Use the round function and in column D round the answer, calculated in column C, as follow. 

o round soccer T-shirts to 1 digit 
o round swimming T-shirts to 2 digits 
o round basketball T-shirts to 3 digits 
o round table tennis T-shirts to 4 digits 

� The answer should appear as follows: 

 
It is not always necessary to round the answer of a cell in a separate cell.  The round function can be 
used with a formula in a cell: =ROUND(formula,number_of_digits) 

 
Formula refers to the formula you want to calculate.  Number_of_digits refer to the number of digits the 
answer should be rounded to. 

 
Activity 33: 
� Use the data entered in Activity 32. 
� Delete the formulas and functions entered in columns C and D. 
� In column C, divide the number of T-shirts for soccer, swimming, basketball, and table tennis by 3 

and round the answer of formula as follows: 
o round soccer T-shirts to 1 digit 
o round swimming T-shirts to 2 digits 
o round basketball T-shirts to 3 digits 
o round table tennis T-shirts to 4 digits 
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� The answer should appear as follows: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
9.4.2. Statistical functions 

Please note cell1 refers to the first cell in the range and cell2 to the last cell in the range and cell11, 
cell12, cell13 refers to selected cells.  Refer to paragraph 9.2 of TL103 for the difference in using a 
comma or colon. 

 
9.4.2.1. Average 

This function calculates the average value for the specified cells or ranges. 
 

=AVERAGE(cell1:cell2) 
Calculates the average of the values in a specified range of cells 

 
=AVERAGE(cell1,cell2,cell3) 
Calculates the average of the values for specified cells 

 
Activity 34: 
� Use the data entered in Activity 31. 
� Delete the formulas in cells B14, B16, B18. 
� In cell B14 calculate the average number of T-shirts for all the types of T-shirts. 
� In cell B16 calculate the average of T-shirts for the swimming, netball and hockey T-shirts only. 
� In cell B18 calculate the average of T-shirts for the rugby, swimming, cricket, hockey and athletic 

T-shirts only. 
� The answer should appear as follows: 
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9.4.2.2. Maximum 
 

This function is used to identify the maximum (greatest, highest, most, largest) value in a range of cells 
or in specified cells. 

 
=MAX(cell1:cell2)  
Calculates the largest value in a specified range of cells 

 
=MAX(cell1,cell2,cell3) 
Calculates the largest value for specified cells 

 
Activity 35: 
� Use the data entered in Activity 31. 
� Delete the formulas in cells B14, B16, B18. 
� In cell B14 calculate the largest number of T-shirts available for all the types of T-shirts. 
� In cell B16 calculate the highest number of T-shirts available for the swimming, netball and hockey 

T-shirts only. 
� In cell B18 calculate the greatest number of T-shirts available for the rugby, swimming, cricket, 

hockey and athletic T-shirts only. 
� The answer should appear as follows: 

 
 
9.4.2.3. Minimum 
 

This function is used to identify the minimum (smallest, least, lowest, tiniest) value in a range of cells or 
in specified cells. 

 
=MIN(cell1:cell2) 
Calculates the smallest value in a specified range of cells 

 
=MIN(cell1,cell2,cell3) 
Calculates the smallest value for specified cells 

 
Activity 36: 
� Use the data entered in Activity 31. 
� Delete the formulas in cells B14, B16, B18. 
� In cell B14 calculate the smallest number of T-shirts available for all the types of T-shirts. 
� In cell B16 calculate the lowest number of T-shirts available for the swimming, netball and hockey 

T-shirts only. 
� In cell B18 calculate the least number of T-shirts available for the rugby, swimming, cricket, 

hockey and athletic T-shirts only. 
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� The answer should appear as follows: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
9.4.3. Financial functions 
 

For all the functions mentioned below, the following definitions apply: 
rate = the interest rate used 
nper = the applicable period 
pmt = the payment/instalment amount 
fv = future value 
pv = present value 
type = 1 if the instalment is paid at the beginning of the month 
type = 0 if the instalment is paid at the end of the month 

 
Please make sure the payment period, interest rate period and the applicable period is all the same 
period/denominator. 

 
Example: 
• Payment is an instalment per month, the interest rate is a % per year and the period is in years. 

• As the payment period is in months you will need to convert the current yearly interest rate to a 
monthly interest rate by dividing the yearly interest rate by 12. 

• As the payment period is in months you will also need to convert the applicable period currently in 
years to a number of months by multiplying the period in years 12. 

Please note, for activity 37 to activity 40, the interest rate should be entered in the spreadsheet 
as 0.14 and formatted to display as 14%.  Refer to paragraph 6.1.1 of TL103. 

 
9.4.3.1. Calculation of payments 
 

=PMT(rate,nper,pv,fv,type) 
Calculates the payment for a loan based on constant payments and a constant interest rate. 

 
Activity 37: 
� You want to buy a car for R50 000.  Enter the present value in cell B3. 
� The bank can finance your car at a constant interest rate of 14% per year over 5 years.  Enter the 

interest rate in cell B4 and the period in cell B5. 
� Use the =PMT function and calculate the monthly payment you need to make to the bank at the end 

of each month. 
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o Enter the following formula in cell B7 =PMT(B4/12,B5*12,B3,0,0) 

 
Structure The formula Explanation 
Begins with = sign =  
Function name PMT  
Opening parenthesis (  

rate B4/12 
The interest rate is an annual (yearly) rate and needs to be divided by 
12 to make it a monthly rate as the payment value required is a monthly 
payment. 

nper B5*12 
The period is a term in years and needs to be multiplied by 12 to make it 
a period in months as the payment value required is a monthly 
payment. 

pv B3 
The present value of the loan amount.  The amount you want to loan 
from the bank to finance the vehicle. 

fv 0 
The future value of the loan.  As the loan will be fully paid by the end of 
the period the future value of the loan is 0. 

type 0 The instalment is paid at the end of the month (paid in arrears). 
Closing parenthesis )  
 

� The answer should appear as follows: 
 
 

Note: As an instalment/payment is 
regarded as an outflow of cash, it is shown 
as a negative value. 

 
 
 
 
 
 
 
 
Activity 38: 

� Use the same information as in Activity 37. 
� Calculate the monthly amount payable to the bank if you pay the amount at the beginning of the 

month (pay in advance) 
o Enter the following formula in cell B7 =PMT(B4/12,B5*12,B3,0,1) 

 
Structure The formula Explanation 
Begins with = sign =  
Function name PMT  
Opening parenthesis (  

rate B4/12 
The interest rate is an annual (yearly) rate and needs to be divided by 
12 to make it a monthly rate. 

nper B5*12 
The period is a term in years and should be multiplied by 12 to make it 
a period in months. 

pv B3 
The present value of the loan amount.  The amount you want to loan 
from the bank to finance the vehicle. 

fv 0 
The future value of the loan.  As the loan will fully be paid by the end of 
the period the future value of the loan is R0. 

type 1 The instalment is paid at the beginning of the month (paid in advance). 
Closing parenthesis )  
 

The answer should appear as follows: 
 

Note: As an instalment/payment is 
regarded as an outflow of cash, it is 
shown as a negative value. 
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9.4.3.2. Calculation of Future Value 
 

=FV(rate,nper,pmt,pv,type) 
Returns the future value of an investment based on constant payments and a constant interest rate. 

 

Activity 39: 
� You want to save R500 at the end of each month and the bank will give you a constant interest rate 

of 14% per year.  Enter the investment amount in cell B3, the investment rate in cell B4 and the 
period in cell B5. 

� Use the =FV function and calculate what the value of your savings will be after 5 years. 
o Enter the following formula in cell B7 =FV(B4/12,B5*12,B3,0,0) 

 

Structure The formula Explanation 
Begins with = sign =  
Function name FV  
Opening parenthesis (  

rate B4/12 
The interest rate is an annual (yearly) rate and needs to be divided by 
12 to make it a monthly rate as you save monthly. 

nper B5*12 
The period is a term in years and should be multiplied by 12 to make it 
a period in months as you save monthly. 

pmt B3 
The payment amount you want to save each month.  Please note that 
the amount is negative (-R500) as it is an outflow of cash to an 
investment. 

pv 0 
The present value of your investment.  As you have not saved anything 
yet the current value (present value) of your investment is 0. 

type 0 You save at the end of each month. 
Closing parenthesis )  
 
The answer should appear as follows: 
 

 
 
 
 
 
 
 
 
9.4.3.3. Calculation of Present Value 
 

=PV(rate,nper,pmt,fv,type) 
Returns the present value of an investment.  The total amount a series of total payments is worth today 
at a constant interest rate and over a constant period. 

 
Activity 40: 
� You have R500 at the end of each month you can use to pay off a loan to the bank.  The bank offers 

you a constant interest rate of 14% per year over 5 years.  Enter the payment in cell B3, the interest 
rate in cell B4 and the period in cell B5. 

� Use the =PV function and calculate what amount you can borrow from the bank. 
o Enter the following formula in cell B7 =PV(B4/12,B5*12,B3,0,0) 

 

Structure The formula Explanation 
Begins with = sign =  
Function name PV  
Opening parenthesis (  

rate B4/12 
The interest rate is an annual (yearly) rate and needs to be divided by 
12 to make it a monthly rate. 

nper B5*12 
The period is a term in years and should be multiplied by 12 to make it 
a period in months. 

pmt B3 
The payment amount you can make each month.  Please note the 
amount is negative (-R500) as it is an outflow of cash to an investment. 

fv 0 
The future value of the loan.  As the loan will be fully paid by the end of 
the period, the future value of the loan is R0. 

type 0 The instalment is paid at the end of the month (paid in arrears). 
Closing parenthesis )  
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� The answer should appear as follows: 

 
 

 
 
 
 
 
 
 
 

9.4.4. Logical functions 
 

=IF(logical_test,value_if_true,value_if_false) 
Returns one value if the specified logical test evaluates to be TRUE and another value if the specified 
logical test evaluates to be FALSE. 

 
Logical_test: 
A logical test is any value or expression that can be evaluated to be either TRUE or FALSE.  For 
example, A1<1000 is a logical test; if A is equal to 500 then the expression evaluates to be TRUE but if 
A is equal to 2000 then the expression will evaluate to be FALSE.  A logical test can evaluate against 
text A1=”yes”, a value A1<1000, another cell A1>=B2 or a formula C5=(A2*B2). 
A logical test usually consists out of 3 parts: 
1. a cell reference, for example A1 
2. a comparison calculation operator i.e. Less than (<); Greater than or equal to (>=); Less than or 

equal to (<=); Not equal to (<>); Equal to(=) 
3. a value, text, cell reference or a formula to evaluate the cell reference in part 1 against.  For 

example 10000, “YES”, B6 or (B5*B6). Please note when using text, the text should be in quotes 
(“”) and is case sensitive. 

 
Value_if_true: 
Which value should be displayed in the cell if the logical test is evaluated to be TRUE.  (The value that is 
returned if logical_test is TRUE) 
The value can either be: 
• text - e.g. “Yes”, “Open” etc.  Please note text should always be in quotes (“”) and is case sensitive. 
• a value e.g.1000.00 or 15090.23.  Please note the value does not have any spaces, commas, or 

currency and that a full stop (.) is use to indicate cents. 
• refer to a cell reference e.g. B5 or E18 
• be a calculation e.g. B5*C7 or B5+30 or A10*0.14 

 
Value_if_false: 
Which value should be displayed in the cell if the logical test is evaluated to be FALSE.  (The value that 
is returned if logical_test is FALSE) 
The value can either be: 
• text - e.g. “close”, “new” etc.  Please note text should always be in quotes (“”) and is case sensitive. 
• a value e.g. 56789.23 or 9874563.  Please note the value does not have any spaces, commas, or 

currency and that a full stop (.) is use to indicate cents. 
• refer to a cell reference e.g. G3 or J50 
• be a calculation e.g. A5-B7 or D5/30 or C10*0.02 

 
 
Activity 41: 
� You have invited a few friends and their children to a soccer match.  The soccer tickets are R30 per 

adult and R15 per child.  You also want to invite the persons 21 years and older to an after party.  
The cost of the after-party is R100 per person. 

� You want to determine: 
o The total cost and cost per person for the soccer tickets only. 
o Whom you want to invite to the after-party, indicated with “Invite”, and whom you do not want to 

invite indicated with “Don’t invite”. 
o The total cost and total cost per person including the after-party and the soccer tickets costs. 

� PLEASE TAKE INTO ACCOUNT THAT ALL FORMULAS WILL ONLY BE ENTERED INTO THE 
FIRST CELL AND COPIED DOWN TO THE FOLLOWING CELLS. 

� Please save this file as “Activity 41” as it will be used in a later activity. 
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� Enter the following data in a spreadsheet: 
 

 A B C D E F 

1 Soccer match and after party     
2       
3 Price per person      
4 Soccer ticket - Adult R 30.00     
5 Soccer ticket - Child R 15.00     
6 After party R 100.00     
7       

8 Name 
Adult/ 
Child Age 

Soccer 
Ticket price 

Invite to 
after party 

Total cost Soccer 
and After-party 

9 Peter Adult 43    
10 Sarah Adult 40    
11 Thabo Child 12    
12 Sandy Child 10    
13 Thomas Child 5    
14 Viwe Adult 32    
15 Abel Child 8    
16 Rikki Child 9    
17 Martin Adult 22    
18 Razia Adult 19    
       

� What will the formula in cell D9 be?  Take into account that you will copy the formula to the rows 
below. 

� Enter the following formula in cell D9 and copy to range D10:D18.  See what happens.  Does the 
formula give you the desired result? 
o =IF(B9=”Adult”,B$4,B$5) 

 

Structure The 
formula 

Explanation 

Begins with = sign =  
Function name IF  
Opening 
parenthesis 

( 
 

logical_test B9=“Adult” 
You want to evaluate if the person is an adult (as indicated in cell B9).   
Please note the relative reference of cell B9.  Also note “Adult” is in quotes 
(“”) because you evaluate against text. 

value_if_the logical 
test is true 

B$4 

You want to return the adult ticket price (entered in cell B4) if the answer to 
your logical test is true, i.e. the person is an adult.  Please note the row 
reference in the cell reference is absolute ($4) as you do not want the row 
reference to increase when the formula is copied downwards. 

value_if_the logical 
test is false 

B$5 

You want to return the child ticket price (entered in cell B5) if the answer to 
your logical test is false i.e. the person is not an adult.  Please note the row 
reference in the cell reference is absolute ($5) as you do not want the row 
reference to increase when the formula is copied downwards. 

Closing parenthesis )  
 

� Delete the formula entered in range D9:D18 
 
� Enter the following formula in cell D9 and copy it to range D10:D18. 

o =IF(B9=“Child”,B$5,B$4) 
 

Structure The formula Explanation 
Begins with = sign =  
Function name IF  
Opening parenthesis (  

logical_test B9=“Child” 
You want to evaluate if the person is a child (as indicated in cell B9).  
Please note the relative reference of cell B9.  Also note “Child” is in 
quotes (“”) because you evaluate against text. 
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value_if_the logical test 
is true 

B$5 

You want to return the child ticket price (entered in cell B5) if the 
answer to your logical test is true i.e. the person is a child.  Please 
note the row reference in the cell reference is absolute ($5) as you do 
not want the row reference to increase when the formula is copied 
downwards. 

value_if_the logical test 
is false 

B$4 

You want to return the adult ticket price (entered in cell B4) if the 
answer to your logical test is false, i.e. the person is not a child.  
Please note the row reference in the cell reference is absolute ($4) as 
you do not want the row reference to increase when the formula is 
copied downwards. 

Closing parenthesis )  
 

� See what happens.  Does the formula give you the desired result?  Is the result different from the 
previous formula entered or is the result the same? 

 
Please note there is usually more than one logical test that can apply in IF functions and the true 
and false value will depend on your logical test. 

 
� What will the formula in cell E9 be?  Take into account you will copy the formula to the rows below. 
� Enter the following formula in cell E9 and copy to range E10:E18.  See what happens.  Does the 

formula give you the desired result? 
o =IF(C9>=21,“Invite”,“Don’t invite”) 

 
Structure The formula Explanation 
Begins with = sign =  
Function name IF  
Opening parenthesis (  

logical_test C9>=21 

You want to evaluate if the person is 21 years and older as per the 
age indicated in cell C9.  Please note the relative reference of cell 
C9.  Also, note that, in contrast to the previous IF formula, the 21 is 
not in quotes because you evaluate against a value and not text. 

value_if_the logical test 
is true 

“Invite” 
You want to return, Invite, if the answer to your logical test is true 
i.e. the person is 21 years and older.  Please note “Invite” is in 
quotes (“”) because you want to return text. 

value_if_the logical test 
is false 

“Don’t invite” 
You want to return, "Don’t invite", if the answer to your logical test 
is false i.e. the person is younger than 21.  Please note “Don’t 
invite”, is in quotes (“”) because you want to return text. 

Closing parenthesis )  
 

� Delete the formula entered in range E9:E18 
 
� Enter the following formula in cell E9 and copy it to cell E10 to E18. 

o =IF(C9<21,“Don’t invite”,“Invite”) 
 
Structure The formula Explanation 
Begins with = sign =  
Function name IF  
Opening parenthesis (  

logical_test C9<21 

You want to evaluate if the person is younger than 21 as per the 
age indicated in cell C9.  Please note the relative reference of cell 
C9.  Also, note the 21 is not in quotes because you evaluate 
against a value and not text. 

value_if_the logical test 
is true 

“Don’t invite” 
You want to return, "Don’t invite" if the answer to your logical test 
is true i.e. the person is younger than 21.  Please note “Don’t 
invite” is in quotes (“”) because you want to return text. 

value_if_the logical test 
is false 

“Invite” 
You want to return, Invite, if the answer to your logical test is false 
i.e. the person is the person is 21 years and older.  Please note 
“Invite”, is in quotes (“”) because you want to return text. 

Closing parenthesis )  
 

� See what happens.  Does the formula give you the desired result?  Is the result different from the 
previous formula entered or is the result the same? 
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As explained previously, more than one logical test can usually apply in IF functions and the true 
and false value will depend on your logical test. 

 
� What will the formula in cell F9 be?  Take into account you will copy the formula to the rows below. 
� Enter the following formula in cell F9 and copy to range F10:F18.  See what happens.  Does the 

formula give you the desired result? 
o =IF(E9=“Invite”,D9+B$6,D9) 

 
Structure The formula Explanation 
Begins with = sign =  
Function name IF  
Opening parenthesis (  

logical_test E9=“Invite” 

You want to evaluate if the person is invited to the after party as 
calculated in cell E9.  Please note the relative reference of cell E9.  
Also note “Invite” is in quotes (“”) because you evaluate against 
text. 

value_if_the logical test 
is true 

D9+B$6 

You want to return the sum of the ticket price (D9) and the after 
party cost (B6) if the answer to your logical test is true i.e. the 
person is invited to the party.  Please note the cell reference for D9 
is relative while the row reference in cell B$6 ($6) is absolute. 

value_if_the logical test 
is false 

D9 
You want to return only the ticket price (D9) if the answer to your 
logical test is false i.e. the person is not invited to the party.  
Please note the relative cell reference for D9. 

Closing parenthesis )  
 
� Delete the formula entered in range F9:F18 

 
� Enter the following formula in cell F9 and copy it to range F10:F18 

o =IF(E9=”Don’t invite”,D9,D9+B$6) 
 
Structure The formula Explanation 
Begins with = sign =  
Function name IF  
Opening parenthesis (  

logical_test E9=“Don’t invite” 

You want to evaluate if the person is not invited to the after party 
as calculated in cell E9.  Please note the relative reference of cell 
E9.  Also note “Don’t invite” is in quotes (“”) because you evaluate 
against text. 

value_if_the logical 
test is true 

D9 
You want to return only the ticket price (D9) if the answer to your 
logical test is true i.e. the person is not invited to the party.  Please 
note the relative cell reference for D9. 

value_if_the logical 
test is false 

D9+B$6 

You want to return the sum of the ticket price (D9) and the after 
party cost (B6) if the answer to your logical test is false i.e. the 
person is invited to the party.  Please note the cell reference for D9 
is relative while the row reference in cell B$6 ($6) is absolute. 

Closing parenthesis )  
 

� Please save this file as “Activity 41” as it will be used in a later activity 
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� The results of Activity 41 should appear as follow: 
 

 
 

 
 

 
To check a formula/function, click on the cell containing the formula/function and press F2.  This 
will indicate to you which cells are used in your formula/function. 

 
 
 
 
 
 
 
 
 

PLEASE REMEMBER: MICROSOFT OFFICE EXCEL WILL DISPLAY IN A CELL, ON THE FACE 
OF THE WORKSHEET, A VALUE OR TEXT BUT BEHIND THAT CELL CAN BE A FORMULA OR A 

FUNCTION. 
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9.4.5. Text functions 
 

Cell refers to the cell you want this function to apply to. 
Please also note that a character is defined as text, number, symbols and spaces. 

 
9.4.5.1. =LEFT(cell,num_chars) 
 

This function returns a specified number of characters (num_chars) from the start (left hand side) of the 
text. 

 
Activity 42: 
� Create a new worksheet 
� Enter the word FUNCTION in cell A3. 
� In cell B3 enter the function =left(A3,3) 
� The answer returned in cell B3 would be the first 3 characters of the word i.e. FUN. 

 
 
 
 

Character 
position/number 

1 2 3 4 5 6 7 8 

 F U N C T I O N 

 
 

Activity 43: 
� Use the same worksheet as in Activity 42 
� Enter the word “F*U NCT+I ON” in cell A4. 
� In cell B4 enter the function =left(A3,5) 
� The answer returned in cell B4 will be the first 5 characters of the word i.e. F*U N.  Please note the 

space between the “U” and “N” is counted as a character. 
 
 
 
 

Character 
position/number 

1 2 3 4 5 6 7 8 9 10 11 12 

 F * U  N C T + I  O N 

 
 
9.4.5.2. =MID(cell,start_num,num_chars) 
 

This function returns a specified number of characters from the middle of a text string given a starting 
position (start_num) and the length specified (num_chars). 

 
Activity 44: 
� Use the same worksheet as in Activity 43 
� In cell C3 enter the function =mid(A3,4,3) 
� The answer returned in cell C3 will be “CTI” 

 
 
 
 
 

Character 
position/number 

1 2 3 4 5 6 7 8 

 F U N C T I O N 

 
 
 
 
 
 
 

Starts here 

Specified number of characters 
num_of_chars 

 

Starts here 
start_num 

Number of characters specified 
num_of_chars 

Specified number of characters 
num_of_chars 

number_of_characters_to return 

Starts here 
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Activity 45: 
� Use the same worksheet as in Activity 44 
� In cell C4 enter the function =mid(A4,7,5) 
� The answer returned in cell C4 would be “T+I O”.  Please note the space between the “U” and “N” 

and the “I” and “O” is counted as a character. 
 
 
 
 
 

Character 
position/number 

1 2 3 4 5 6 7 8 9 10 11 12 

 F * U  N C T + I  O N 

 
 
 
 
 
 
9.4.5.3. =RIGHT(cell,num_chars) 
 

This function returns a specified number of characters (num_chars) from the end (right hand side) of the 
text. 

 
Activity 46: 
� Use the same worksheet as in Activity 45 
� In cell D3 enter the function =right(A3,3) 
� The answer returned in cell D3 will be “ION” 

 
 
 
 
 

Character 
position/number 

1 2 3 4 5 6 7 8 

 F U N C T I O N 

 
Activity 47: 
� Use the same worksheet as in Activity 46 
� In cell D4 enter the function =right(A3,5) 
� The answer returned in cell D4 will be “+I ON”.  Please note the space between the “I” and “O” is 

counted as a character. 
 
 
 

 
 
 
 
 

 
� The results of Activity 42 to Activity 47 should appear as follow: 

 

  
 
 
 
 
 

Character 
position/number 

1 2 3 4 5 6 7 8 9 10 11 12 

 F * U  N C T + I  O N 

Specified number of characters 
num_of_chars 

 

Specified number of characters 
num_of_chars 

number_of_characters_to return 

Starts here 
start_num 

 

Starts here 

 

Specified number of characters 
num_of_chars 

number_of_characters_to return 

Starts here 
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9.4.6. Lookup functions 
 

Vertical lookup: =VLOOKUP(lookup_value,table_array,col_index_num,range_lookup) 
This function searches for a value in the leftmost (first) column of a range of cells, and returns a value in 
the same row from a column you specify. 

 
Lookup_value: 
This value is the value you want to search in the first column of the table_array (refer to table array 
below).  Lookup_value can be a value, a cell reference or text.  VLOOKUP returns the #N/A error value 
where the lookup_value is smaller than the smallest value in the first column of table_array, 

 
Table_array: 
This range of cells (two or more columns) contains the data you want to look up.  The lookup_value 
searches the values in the first column of the table_array.  The values in the first column of table_array 
can be text, numbers or values, uppercase and lower case text are equivalent. 
• If the range lookup is set as TRUE then the table_array should be sorted in ascending order based 

on the first column.  Refer to paragraph 10.1 of TL103 on how to sort data. 
• If range_lookup is set as FALSE the table_array lookup value should be unique (primary key). 
• The data in the first column of table_array should not contain leading spaces, trailing spaces, 

inconsistent use of quotation marks or nonprinting characters as vlookup might return an incorrect of 
unexpected value. 

• When searching for number or date values make sure the data in the first column of table_array is not 
stored as text but as values. 

 
Col_index_num: 
This is the column number in table_array (refer to table_array above) from which the matching value 
should be returned.  1 will return the value in the first column of the table_array while 2 return the value 
in the second column of the table_array. 
• VLOOKUP will return a #VALUE! error if the col_index_num is less than 1. 
• VLOOKUP will return a #REF! error if the col_index_num is greater than the number of columns in 

table_array. 
 

Range_lookup: 
This specifies whether you want VLOOKUP to find an exact match or an approximate match. 
• When set as TRUE an exact or approximate match is returned i.e. if an exact match is not found, the 

next largest value that is less than lookup_value is returned. 
• When set as FALSE an exact match is found and the error value #N/A returned if no match is found.  

If there is more than 1 value in the first table_array that matches the lookup_value then the first value 
found is used. 
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Activity 48: 
� Create a new worksheet 
� Enter the following data in the worksheet 

 
 A B C D 
1 Assignment mark list    

2 Student nr Name 
Assignment 
mark 

 

3 123456 Peter 80  
4 234567 Sarah 65  
5 345678 Thabo 34  
6 456789 Sandy 56  
7 567890 Thomas 48  
8 678901 Viwe 78  
9 789012 Abel 51  
10 890123 Rikki 49  
11 912345 Martin 63  
12     
13 Exam mark list    
14 Student nr Name Exam marks  
15 789012 Abel J 64  
16 912345 Martin Q 57  
17 123456 Peter R 45  
18 890123 Rikki B 49  
19 456789 Sandy D 53  
20 234567 Sarah M 62  
21 345678 Thabo H 72  
22 567890 Thomas V 55  
23 678901 Viwe C 46  

 
� You want to create one list with both the exam marks and final marks beside each student’s name.  

You have decided to reflect the exam marks beside the assignment marks but you do not want to go 
and find each student’s exam marks manually and then type it beside the assignment marks.  You 
also know the student number is unique to each student and reflected in both sets of data.  How can 
you do this? 

� You can use the VLOOKUP.  What formula will you enter? 
 

� In cell D3 enter =VLOOKUP(A3,A$15:C$23,3,FALSE) 

 
Structure The formula Explanation 
Begins with = sign =  
Function name VLOOKUP  
Opening parenthesis (  

Lookup_value A3 
The value you want to look up in the exam mark list (table_array) is the 
student number, which is reflected in cell A3. 

Table_array   
 

A$15:C$23 

You will find the data for the exam marks in this range of cells.  Please 
note the student number is in the 1

st
 column (A) of the data range 

because the value you are looking for should always be in the 1
st
 

column.  Also note the row references are absolute as you do not want 
the data range reference to change when you copy the formula. 

Col_index_num 3 The exam marks are in column C, the 3rd column of the table_array. 

Range_lookup FALSE 
It is set as FALSE because you want to find the exact match for the 
student number. 

Closing parenthesis )  
 

� Copy the formula in cell D3 to range D4:D11. 
� Check and see if the formula gave the correct exam mark to the correct student. 
� Why was the student name not used as lookup_value?  Because there might be more than one 

student with the same name and because the student name in the 2 lists are not EXACTLY the 
same. 
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� The results should appear as follow: 
 

 
 
 
 
 
 

 

Table_array 
Range where 
you can find 
the data 

Lookup_value 
The value you 
want to find in 
the table_array 
(exam mark list) 
1

st
 column  

Col_index
_num: 1 

Col_index
_num: 2 

Col_index
_num: 3 

The values (always in 
the 1

st
 column), which 

the lookup function will 
search, to see if there 
is an exact match 
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Activity 49: 
� Create a new worksheet. 
� You have calculated the taxable income for a number of friends and now want to determine their 

applicable tax rate. 
� You have created the following spreadsheet with each person’s taxable income as well as the tax 

table. (Enter the following data in the worksheet) 
 

 A B C D 
1 Taxable income     
2 Name Taxable income Fixed tax amount Tax rate 
3 Peter 358,000.00   
4 Sarah 279,000.00   
5 Thabo 125,000.00   
6 Sandy 86,000.00   
7 Thomas 198,600.00   
8 Viwe 412,300.00   
9 Abel 567,000.00   
10 Rikki 654,000.00   
11 Martin 220,000.00   
12         
13 Tax table       
14 

Taxable income Fixed tax amount 
Tax rate above lower 

bracker-1 
15 Lower bracket Upper bracket     
16 1.00 122,500.00 0 18% 
17 122,501.00 195,000.00 21,960 25% 
18 195,001.00 270,000.00 40,210 30% 
19 270,001.00 380,000.00 62,710 35% 
20 380,001.00 490,000.00 101,210 38% 
21 490,001.00   143,010 40% 

 
� You do not want to look up each person’s fixed tax amount and tax rate individually but want to use a 

Microsoft Office Excel formula.  Which formula will you enter in cell C3?  You will copy this formula to 
the rows below. 

� In cell C3 enter =VLOOKUP(B3,A$16:D$21,3,TRUE) 
 
Structure The formula Explanation 
Begins with = sign =  
Function name VLOOKUP  
Opening parenthesis (  
Lookup_value B3 The value you want to look up in the tax table (table_array) is the taxable 

income, which is reflected in cell B3. 
Table_array   A$16:D$21 You want to look for the values in the tax table, which can be found in 

this range of cells.  Please note the value for which the lookup_value is 
looking for should be in the 1

st
 column of the data range (column A in 

this example).  Also, note the row references are absolute as the cell 
references should not change when you copy the formula downwards. 

Col_index_num 3 After you find the row with the data you are looking for, this tells the 
function which column’s data you want to be returned.  The fixed tax 
amount is in column C, the 3rd column of the table_array. 

Range_lookup TRUE It is set as TRUE because you want to find the next largest value that is 
less than lookup value i.e. you want to find the lower bracket of the tax 
group. 

Closing parenthesis )  
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� In cell D3 enter =VLOOKUP(B3,A$16:D$21,4,TRUE) 
 
Structure The formula Explanation 
Begins with = sign =  
Function name VLOOKUP  
Opening parenthesis (  
lookup_value B3 The value you want to look up in the tax table (table_array) is the 

taxable income, which is reflected in cell B3. 
Table_array   A$16:D$21 You want to look for the values in the tax table, which can be found 

in this range of cells.  Please note the value for which the 
lookup_value is looking to match against should be in the 1

st
 

column (column A in this example) of the data range.  Also, note 
the row references are absolute as the cell references should not 
change when you copy the formula downwards. 

Col_index_num 4 This tells the function which column’s data you want to be returned 
of the row the data you are looking for is in.  The tax rates are in 
column D, the 4th column of the table_array. 

Range_lookup TRUE It is set as TRUE because you want to find the next largest value 
that is less than lookup value i.e. you want to find the lower bracket 
of the tax group the taxable amount belongs in. 

Closing parenthesis )  
 

� Copy the formula in C3 to range C4:C11 and copy the formula in D3 to range D4:D11 
� The results should appear as follows: 

 
 

  
 
 
 
 
 

Col_index
_num: 1 

Col_index
_num: 3 

Col_index
_num: 4 

Lookup_value 
The value you 
want to find in 
the table_array 
(tax table) 1

st
 

column 

Table_array 
Range where 
you can find 
the data 

The values (always in 
the 1

st
 column), which 

the lookup function will 
look at, to see where 
the amount is which is 
just smaller than the 
look_up value 

Col_index
_num: 2 
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WORKING WITH DATA 
 

Refer to paragraph 7.4.5.12 and 7.4.5.13 in ISBE. 
 
9.5. Sorting data 
 

Sorting data is a great tool to use when analysing data.  You can use it to put a list of names in 
alphabetical order, arrange amounts from highest to the lowest or from biggest to smallest or arrange 
dates from earliest to latest.  You can either sort the data in ascending order (going up/lowest to the 
highest) or descending order (going down/highest to lowest).  You can also sort the data based on 
sorting criteria for more than one column. 

 
Make sure you select the whole range you want to sort and not just the column on which you want to 
base the sort.  The data in the other columns beside will not follow the sort if you only select the column 
you want to base the sort on. 

 
Activity 50: 
� Use the completed spreadsheet of Activity 41 
� We firstly want to sort the adult and child indicator per column B so that all the children are reflected 

first.  With that, we also want to sort the ages for each group (column C) from youngest to oldest. 
� Select range A8:F18. 
� Click on the Data tab 
� In the Sort & Filer group, click on the Sort icon 
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� This will open the following Sort dialogue box. 
 

 
 

� Ensure the My data has headers box has been ticked 
� Click on the arrow in the Sort by dialog box and select Adult/child from the drop-down menu 
� Click on the arrow in the Sort on dialog box and select Values from the drop-down menu 
� Click on the arrow in the Order dialog box and select Z to A from the drop-down menu 

 

 
 

� Click on Add Level 
� Click on the arrow in the Then by dialog box and select Age from the drop-down menu 
� Click on the arrow in the Sort on dialog box (in the Then by row) and select Values from the drop-

down menu 
� Click on the arrow in the Order dialog box (in the Then by row) and select Smallest to Largest from 

the drop-down menu 
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� Your complete selection will appear as follows: 
 

 
 

� Select OK to action the sort. 
� The result of the sort will appear as follows: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

 
9.6. Filter data 
 

Filtering data allows you to display only the rows that meet your specified criteria and hide the rows you 
do not want displayed.  You can also filter by more than one column but remember filters are additive, 
which means each additional filter is based on the current filter, and further reduces the subset of data.  
The filter will only apply to the selected data range.  You can copy, find, edit, format, chart, and print the 
subset of filtered data without rearranging or moving it.  You can only filter by a list values, a format, or 
by criteria.  However each of these filters is mutually exclusive, you can for example, filter by font colour 
or by a list of numbers, but not by both. 

 
Activity 51: 
� Use the completed spreadsheet of Activity 41 
� Select range A8:F18 
� Click on the Data tab 
� In the Sort & Filter group, click on the Filter icon 
� This will create drop-down arrows next to each column heading 

 

 
 
 
 
 

Drop-down 
arrow 
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� Click on the drop-down arrow next to “Invite to 

after party” 
� In the drop-down menu only select “Don’t 

invite”. 
� Click on OK 

 
 

 
 
 
 
 
 

� Only the rows with “Don’t invite” in that column is displayed and it will appear as follow: 
 

 
 

� Did you notice that: 
o The filter icon is displayed on the drop-down arrow next to “Invite to after party”.  This indicates 

there is a filter applied on that column. 
o The row reference displayed seems to be missing rows i.e. only rows 1 to 8, 11 to 13 and 15 to 18 

are displayed.  The applied filter did not delete rows 9, 10 and 14 but only hid them. 
� We now only want display all the persons that were not invited but are younger than10.  To do this we 

will apply a further filter.  (remember filters are additive) 
 

� Click on the drop-down arrow next to “Age” and select Number Filters. 
� In the drop-down menu under select Less Than… 
� This will open the Custom AutoFilter dialog box 
� Click on the box right of is less than and either type 10 or select 10 from the drop-down menu 
� Click OK to action the filter 
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� Only the rows with “Don’t invite” in column E and where the persons age (column C) is less than 10 

are displayed and the rest of the rows are hidden.  The spreadsheet will appear as follows: 
 

 
 

� Did you notice that: 
o The filter icon is displayed on the drop-down arrow next to “Invite to after party” and “Age”.  The 

filter icon indicates there is a filter applied on that column. 
o The row reference displayed seems to be missing rows i.e. rows 1-8, 13, 15, 16 are displayed but 

not the other rows.  The applied filters did not delete the other rows but only hid them. 
 

• To remove a filter from a column click on the applicable column’s drop-down arrow and select (Select 
All).  You can also change the filter by clicking on the applicable column’s drop-down arrow and 
selecting the new filter you want to apply. 

 

 
 

• To remove filtering in total from the data range follow the following steps: 
o Select the data range which was filtered 
o Click on the Data tab 
o In the Sort & Filter group, click on the Filter icon to deselect the filter option 
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10. WORKING WITH CHARTS 
 

Charts are a visual/graphical presentation of data and are very useful to help with the understanding and 
interpretation of the data presented.  Charts sometimes make it is easier to identify trends in data.  
Remember persons looking at a chart do not have the underlying data in front of them so it is very 
important to make sure the following is always included in a chart: 

 
• A chart title.  This is the title of your chart and indicates what your chart is all about. 
• Category-axis title.  This is a short description of the categories on the category-axis e.g. months, 

item codes, etc.  Charts mostly display categories on the horizontal axis, but Bar charts display 
categories on the vertical axis. 

• Value-axis title.  This is a short description of the values on the Value-axis e.g. rand, number, 
percentage, etc.  Charts mostly display values on the vertical axis, but Bar charts display values on 
the horizontal axis. 

• Category-axis scale label.  This describes each Category-axis scale label e.g. if your Category-axis 
title is for example “Months” the scale label will probably be “January”, “February”, “March”, etc. 

• Legend.  This indicates what colour represent which particular data series. 
 

Refer to paragraph 7.4.8 in ISBE for how to work with charts. 
 
10.1. Creating a Chart 
 

To create a chart, follow the steps below: 
 

Activity 52: 
� Create the following data in a new Workbook file on Sheet1. 

o “Total sales R (Actual)” is calculated as the applicable number of “Items sold (Actual)” * R150 
o “Total sales R (Budget)” is calculated as the applicable number of “Items sold (Budget)” * R100 

� Save the Workbook file as “GRAPH” 
 

 A B C D E 
1 SA Textbooks Pty Ltd   

2      

3 
 Items sold 

(Actual) 
 Items sold 
(Budget) 

Total sales R 
(Actual) 

Total sales R 
(Budget) 

4 Jan 1567 1500 235,050 150,000 
5 Feb 975 1000 146,250 100,000 
6 Mar 445 560 66,750 56,000 
7 Apr 1249 1300 187,350 130,000 
8 May 368 300 55,200 30,000 
9 Jun 1345 1100 201,750 110,000 

 
� Select range A3:C7 

 
 
 
 
 
 

� While the above-mentioned 
range is selected 

� Click on the Insert tab 
� In the Chart group, click on 

the arrow next to the 
Column icon 

� In the drop-down menu 
select 2D Clustered 
Column (Tip:  Hovering 
with your mouse pointer 
over the different chart 
icons will make the 
description of the icon 
appear) 

Excel is very particular when a data range is selected.  The range SHOULD be selected correctly the 
first time.  For example in this activity do not move your mouse pointer over column D and then back to 

column C 
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� You will note that the graph inserted into your worksheet is basic without any graph and axis titles, 
etc.  You are going to update the graph to be more user-friendly. 

� Click on the graph to have the Chart Tools commands displayed. The Chart Tools will add 3 more 
tabs: Design, Layout and Format 

 
 

 
� Click on the Layout tab 
� In the Labels group, click on the arrow next to the Chart title icon 
� In the drop-down menu select Above Chart 
� This will open a Text box in the chart area above the chart with the text “Chart title”. 
� Click in the text box and delete “Chart Title”.  Type in “Textbooks sold per month” 
� In the textbox highlight “Textbooks sold per month” 

o Click on the Home tab and change the Font of the Chart title to: Arial, font size 16, Bold and Italic 
 

� Click on the Layout tab 
� In the Labels group, click on the arrow next to the Axis Titles icon 
� In the drop-down menu click on the arrow next to Primary Horizontal Axis Title 
� In the drop-down menu select Title Below Axis 
� This will open a text box in the chart area, below the chart, with the text “Axis title” 
� Click in the box and delete “Axis title”. Type in “Months” 

 

 
 

 
 

� Click on the Layout tab 
� In the Labels group, click on the arrow next to the Axis Titles icon  
� In the drop-down menu click on the arrow next to Primary Vertical Axis Title  
� In the drop-down menu select Vertical Title  
� This will open a text box in the chart area, left of the chart, with the text “Axis title”. 
� Click in the box and delete “Axis title”. Type in “Number”  
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� Click on the Design tab 
� In the Location group, click on the Move 

Chart icon 
� Select New sheet: and change the name 

from Chart1 to Number 
� Click on OK 
� Did you notice that the graph was moved to 

a new worksheet called “Number” 
� Save the workbook file “GRAPH” 
� The graph you created should appear as 

follows: 

 
 

Activity 53: 
� Use the worksheet created in Activity 52 i.e. the file called “GRAPH” 
� Select ranges A3:A9 AND D3:E9 simultaneously by using the control key. 

o This is done by selecting range A3:A9 
o While the above mentioned range is selected press the “CTRL” (control) key on the keyboard 
o While the “CTRL” (control) key is pressed select range D3:E9 with the mouse 

� While the above-mentioned range is selected click on the Insert tab 
� In the Chart group, click on the arrow next to the Line with Markers icon 
� In the drop-down menu select 2D Line (Tip: Hovering with your mouse pointer over the different chart 

icons will make the description of the icon appear) 
� You will note that the graph inserted into your worksheet is basic without any graph and axis titles, 

etc. 
 

� Click on the graph to have the Chart Tools commands displayed. 
� Click on the Layout tab 
� In the Labels group, click on the arrow next to the Chart title icon 
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� In the drop-down menu select Above Chart 
� This will open a Text box in the chart area above the chart with the text “Chart title” 
� Click in the text box and delete “Chart Title”.  Type in “Total sales per month” 

 
� Click on the Layout tab 
� In the Labels group, click on the arrow next to the Axis Titles icon 
� In the drop-down menu click on the arrow next to Primary Horizontal Axis Title 
� In the drop-down menu select Title Below Axis 
� This will open a text box in the chart area, below the chart, with the text “Axis title” 
� Click in the box and delete “Axis title”. Type in “Month” 

 
� Click on the Layout tab 
� In the Labels group, click on the arrow next to the Axis Titles icon 
� In the drop-down menu click on the arrow next to Primary Vertical Axis Title 
� In the drop-down menu select Rotate Title 
� This will open a text box in the chart area, left of the chart, with the text “Axis title” 
� Click in the box and delete “Axis title”. Type in “Rand” 

 

 
 
 
 

� Click on the Layout tab 
� In the Labels group, click on the arrow next to the Legend icon 
� In the drop-down menu select Show Legend at Bottom 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
� Click on the Design tab 
� In the Location group, click on the Move Chart icon 
� Select Object in: and select Sheet2 from the drop-down menu (click on the arrow to activate the 

menu) 
� Click on OK 
� Did you notice that the graph was moved to Sheet2 
� Save the workbook file “GRAPH” 
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� The graph you created should appear as follows: 
 

 
 

Note the difference in the look and feel between moving the chart to a New sheet or to an Object in. 
 
10.2. Updating data in a chart 
 
10.2.1. Updating source data 
 

You can update the range of data the chart is reading after it was created.  You will for example use this 
to add additional month’s information as it become available. 

 
Activity 54: 
� Click on the chart created in Activity 52 
� Click on the Design tab 
� In the Data group, click on the Select data icon 
� This will open the Select Data Source Data dialog box 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

� Note your current data selection has dotted lines around it. 
� Also note the current Chart data range:  ='Sheet1'!$A$3:$C$7 
� Update the data range to include May and June’s data by: 

o Click on the table with the data and Re-selecting the data range(i.e. A2:C9) by including the new 
data range  (Note that your new data selection has dotted lines around it) or 

o By changing the information in the Chart data range: box from  ='Sheet1'!$A$3:$C$7 to 
=Sheet1!$A$3:$C$9 
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� Click on OK to action the change 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
� The updated graph will appear as follows: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
10.2.2. Changing the chart type 
 

Microsoft Office Excel provides many different type of charts, including 3D charts.  You can change the 
type of a created chart after you have created it. 

 
Activity 55: 
� Click on the chart created in Activity 53 or Activity 54 
� Click on the Design tab 
� In the Type group, click on the Change Chart Type icon 
� This will open the Change Chart Type dialog box 
� Experiment by choosing different types of charts 
� Click on OK to action the change 
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10.2.3. Changing the chart layout and format 
 

You can customise your chart to give it your own individual look.  You can for example apply specific 
shape styles; format the shapes and text of chart elements. 

 
Activity 56: 
� Click on the chart created in Activity 53, Activity 54 or Activity 55 
� Click on the Layout and Format Tab 
� Experiment by selecting different icons on both these tabs 
� Click on OK to action the changes 

 
 
 
 
11. FREQUENT MISTAKES IN MICROSOFT OFFICE EXCEL QUESTIONS 
 

When marking a Microsoft Office Excel question 1 mark per error will be deducted for the following.  
Please note we will only deduct marks until you have zero for a formula, you can therefore not get a 
negative mark for that specific formula. 

 
• Not starting the formula with = 

Correct Loose 1 mark 
=sum(B5:B19) sum(B5:B19) 
=if(C3>B4,500,1000) if(C3>B4,500,1000) 

 
• Using [ ] instead of ( ) 

Correct Loose 1 mark 
=sum(B5:B19) =sum[B5:B19] 
=if(C3>B4,500,1000) =if[C3>B4,500,1000] 

 
• Incorrect use of parentheses ( ) 

Correct Loose 1 mark 
=sum(B5:B19) =sum(B5:B19 
=if(C3>B4,500,1000) =(ifC3>B4,500,1000) 
=sum(B5:B19) =sumB5:B19) 

 
• Using ; instead of : or , (please refer to paragraph 9.2 of TL103) 

Correct Loose 1 mark per incorrect syntax 
=sum(B5:B19) =sum(B5;B19)  1 mark lost 
=if(C3>B4,500,1000) =if(C3>B4;500;1000) 2 marks lost 

 
• Using SUM in a formula where it is not applicable 

Correct Loose 1 mark 
=B5+B10 =sum(B5+B10) 
=B10*B4 =sum(B10*B4) 
=B5/B10 =sum(B5/B10) 

 
• Not using “ ” when using text in a formula 

Correct Loose 1 mark per incorrect syntax 
=if(C3=“yes”,“open”,“close”) =if(c3=yes,“open”,“close”) 1 mark lost 
=if(C3=“yes”,“open”,“close”) =if(c3=“yes”,open,close) 2 marks lost 
=if(C3=“yes”,“open”,“close”) =if(c3=yes,open,close) 3 marks lost 
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• Using mathematical signs instead of Microsoft Office Excel signs 

Correct Loose 1 mark 
* x 
/ ÷ 

 
• Using a formula when a function is available 

Correct Loose 1 mark 
=sum(B5:B10) = B5+B6+B7+B8+B9+B10 
=average(B5:B10) =(B5+B6+B7+B8+B9+B10)/6 

 
• Incorrect writing of values/amounts in a formula or function 

Correct Loose 1 mark 
0.1 0,1 
100000 100 000 or R100000 or 100,000 

 
Congratulations – you have finished working through your Microsoft Office Excel tutorial letter!  I hope 
you have enjoyed learning about Microsoft Office Excel and will be able to apply what you have learned 
in the workplace! 
 

Note: Microsoft product screen shots reprinted with permission from Microsoft Corporation 


